[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Boot Problems

Hello All!

A few days ago I posted a problem I'm having at home making a custom kernel
that I can boot.  I'm reposting now with some information.

I run Dos/Windows on my first SCSI drive, /dev/sda, which has three
partitions plus the boot sector.  I run OS/2 and Linux on my second SCSI
drive, which has partitions for OS/2, Debian, Swap, and the boot sector. 
I'm using the OS/2 boot manager to invoke lilo, which then boots Linux.

I have built a custom kernel (2.0.30) to remove unnecessary file system
support, and add IP Masquerading. I've followed the instructions in
/usr/src/linux/README.  I've made a boot floppy with the new kernel, and I
ran "rdev /dev/fd0 /dev/sdb6" where sdb6 is the Linux partition on my
second SCSI drive.  I then ran "rdev /dev/fd0" to verify the floppy was
pointing to /dev/sdb6, and it reported correctly.  When I reboot the
machine from the floppy, a screen of preliminary configuration info is
displayed, then I get a kernel panic with the message: VFS: can't mount
boot device 8:16.

I've been reading the messages regarding 16 partitions per SCSI drive.  I
specifically configured (using rdev) to boot to /dev/sdb6.  I don't yet
understand all about the major/minor stuff.  I plan to read more this
weekend.  When I run lilo on my kernel on the hard drive, and reboot, I get
the same message as when I boot from floppy. 

The originally installed kernel (from the 2 CD set) boots fine.  I have
remembered to set /vmlinuz to point to the correct kernel, and I ran lilo
to update the System.map.

Any help and suggestions would be very welcome.  I want to learn how to
build a bootable kernel, so I can add masquerading and sound capability.

Thanks in advance for any help.


TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: