[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: How to multitask in X-windows?

Hi ImmortaL:

I have your problem with Netscape. I hope we both get an answer.

I hope this helps part of your other window problem: It sounds a little
like you have a 'focus' problem. I can click the mouse and create X
windows that work if I move the mouse pointer into the window to get
"focus" in that window. Notice the color changes when the mouse pointer
is in a window or out of it. That's called having "focus" - (strange
parlance, but what do you expect from computer types :)

I can run stuff in the background and change windows if I have focus in
that window. (X can be setup so you have to click a window to change
focus, as in M$ LOSE 3.1 & 95)

With regard to switching from text consoles back to X you use
Control-Alt F1-6 to move to a virtual text console, and from one of them
back to X you use Control-F7 (at least I do). 

MY PROBLEM is somewhat like ImmortaL's:

Will someone PLEASE explain why when I suspend Emacs in X with control
z, and try to restart it with fg, emacs does not reappear. Key strokes
are echoed but no keystrokes are accepted by emacs. I wind up killing
emacs. And tell me how to suspend and restart a program under X. 

Am I supposed to open a window and start an application there, changing
from window to window to do various things?

           LINUX: the FREE 32 bit OS for [345]86 PC's available NOW!
David B Teague | User interface copyrights & software patents make 
teague@wcu.edu | programing a dangerous business. Ask me or lpf@lpf.org

spy counter-intelligence wild porno sex gold bullion Soviet Bosnia clipper
National Security Council explosion Treasury terrorist Delta Force bomb Iran
Mossad data encryption munitions Serbian hydrazine ammonium nitrate fuel oil  

On Wed, 1 Oct 1997, ImmortaL wrote:

> Actually your both right because my question can go both ways it doesnt
> matter they both are helpful BUT,i tried both ways and they dont work for
> example if i enter X and start netscape and then go back to Xterm i cant
> enter any commands its locked until i kill netscape,i tried it only with
> Xterm i opened two Xterms but the first one didnt work after i opened the
> second one.Then tried the Virtual way Ctrl-alt-Fx and when i did that and a
> new logon screen came on and then when i went back to X there was no X
> there was a shell screen and it showed all the usual commands when X starts
> and it was locked.and i cant do anything so i have to kill it.Do you have
> to be running XDM for it to work?Or do you have any idea why this wont
> work?
> Thanks
> wicked@ziplink.net
> Jason Costomiris <jcostom@sjis.com> wrote in article
  [ useful stuff omitted ...]

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: