[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Upgrade procedure for tetex

On Fri, 28 Feb 1997, Christoph Martin wrote:

> - Purge all the old tex packages which are replaced by tetex. (E.g. go
> into dselect, select the tetex-packages, look which old tex packages
> are marked to be removed, purge the packages.)
> tetex replaces: amslatex, amstex, babel, bibtex, dvipsk, kpathsea,
> kpathsea-dev, latex, latex2e-doc, ltxmisc, ltxtool, makeindex,
> mfbasfnt, mfdcfnt, mflib, mfnfss, ps2pk, psnfss, texbin, texi2html,
> texinfo, texlib, texpsfnt, textmf, xdvik 

a cut & paste solution is:

dpkg --purge --force-depends amslatex amstex babel bibtex dvipsk kpathsea kpathsea-dev latex latex2e-doc ltxmisc ltxtool makeindex mfbasfnt mfdcfnt mflib mfnfss ps2pk psnfss texbin texi2html texinfo texlib texpsfnt textmf xdvik

note, the --force-depends is necessary. babel wont uninstall cleanly
without it...

Then use dpkg or dselect to install the tetex packages.

(assuming you have a mirror of debian mounted at /debian:)

cd /debian
dpkg -i bo/binary/tex/tetex-base_0.4pl6-2.deb bo/binary/tex/tetex-bin_0.4pl6-4.deb bo/binary/tex/tetex-dev_0.4pl6-4.deb bo/binary/tex/tetex-doc_0.4pl6-1.deb bo/binary/tex/tetex-extra_0.4pl6-2.deb

tetex-bin still comes up with some warning messages about "ls -lR" files
missing - i don't know how serious this is...it does install cleanly.
texconfig has an option to make the ls-lR files, so i doubt if it's big


Reply to: