[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: missing/non-functional identd service?

Pete Templin typed:
> Hi there.
> I've been learning about PGP, and was in the process of taking a look at a
> few public keys, when I ran into a small stumbling block.  You see, I was
> fingering bruce@master.debian.org when I ran into a small obstacle:
> tcsh> finger bruce@master.debian.org
> [master.debian.org]
> Debian Linux 1.1  Copyright (C) 1993-1996 Debian Association, Inc. and
> others
>                  Your site has been rejected for some reason.
>          This may be caused by a missing RFC 1413 identd on your site.

I get this too at work, but to make it even worse it is via a firewall.  I
might write a bodgy script to get around this.

RFC 1413 is identd.  It is used to work out who on a machine "owns" that
connection, which means it is next to useless on a firewall.

Now we also, temporarily, have a problem on the firewall; its address cannot
be reverse resolved (ie IP address -> hostname>.  Does this security thing
balk due to that too?

I don't have the same problem when I connect to my own machine as I have
identd running here.

> Is this a configuration error I need to fix, a package I haven't
> installed, or something else?  It would seem best if Debian systems could
> at least finger Debian systems, right?

I'd say you would need identd, try telnetting to ident and type
anything and see what happens, if you get something coming back like ERROR :
INVALID REQUEST then you have identd running.

  - Craig
  // /\   |  | |  Craig Small VK2XLZ     @home: csmall@gonzo.triode.net.au
 ||==||===|==|=|  []         @play: csmall@gonzo.vk2xlz.ampr.org
  \\ \/   |  | |  finger csmall@triode.net.au for PGP key!

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-REQUEST@lists.debian.org . Trouble? e-mail to Bruce@Pixar.com

Reply to: