[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

1.2.0 installation problems

Hello everyone,

 I just moved to debian from another distribution (DLD). I got it from the
 December 1996 Developers Ressource of InfoMagic (it's Debian 1.2.0, I think).
 I really liked the way it installs (though it could work without floppies
 like RedHat or my older distribution - maybe in a future version?)
 Unfortunately I have some major problems:
 1) Choosing some X based applications in 'dselect' says that X11R6 is needed
    but seems not to be available (can't understand this; maybe a problem in
    some configs)
 2) startx doesn't work correctly (I did run configure in dselect and I
    successfully created a configuration by xf86config). In fact the X
    server seems to start but shuts down itself shortly after that. Here is
    what it says:
    PEX extension module not loaded
    XIE extension module not loaded (don't know what this means and if these
                                     are really errors)
    waiting for X server to shut down

    In .xsession-errors I read:
    /usr/X11R6/bin/fvwm95-2: can't load library `libXpm.so.4'

    This leads to
 3) Because of 2) I tried ldd fvwm95-2 and I get
     libXpm.so.4 => not found
     libXext.so.6 => not found
     libX11.so.6 => not found
     libc.so.5 => /lib/libc.so.5.4.13

    So I searched for these libraries and I found them in /usr/X11R6/lib
    I tried ldconfig, but it didn't help. Why aren't these libraries used?

 4) I wasn't able to boot the supplied kernel anymore after the installation.
    It locked during some CD-ROM autoprobing. So I booted an older kernel
    from my former distribution. Well, you will know that there are many
    problems. Modules from the older and the supplied kernel didn't work
    together (though both are from 2.0.27) and I couldn't access neither my
    ATAPI CD-ROM nor my DOS partition.
    Anyway, I wanted to compile a new kernel. I used the common procedure:
     cd /usr/src/linux
     make config
     make dep
     make clean
     make zImage
    After some time of compiling it gives the following error and aborts:
    fs/fs.o: In function `binfmt_setup`:
    fs/fs.o(.text+0x9531): undefined reference to `init_elf_binfmt`
 5) This one is less important, but I'm curious about the reason and how to
    handle it: 'dselect' says that there is a conflict between ctags for
    emacs and ctags for vim.

Well, this are problems I was facing during the installation. There is another
one in installing xemacs, but I couldn't dig deeper into it yet.

I hope you can help me. If some of the questions are already answered in the
list please answer it again, because I just recently subscribed.

Thanks in advance,


#  http://www.phy.tu-dresden.de/~ujr                      #
# mailto:ujr@physik.phy.tu-dresden.de             ++      #
# finger for PGP key  (1024/7695B00D)      :\:| , :| :::| #
#                                          `::| \::/ :|   #
# A witty saying proves nothing.                          #

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-REQUEST@lists.debian.org . Trouble? e-mail to Bruce@Pixar.com

Reply to: