[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

X programs can't find 'libX11.so', 'libXaw.so', etc.

Help!  After fixing my /etc/ld.so.conf to get the loader to look in
usr/X11R6/lib (which fixed Metafont), I am still having problems with X
programs being unable to find their libraries.  For example, I got the
binaries for "xv"  from Sunsite, but when I run it I get: 

xv: can't load library '/usr/lib/libX11.so.3'
        Unknown error
xv: can't load library '/lib/libX11.so.3'
        Unknown error
xv: can't find library 'libX11.so.3'

I tried making a symlink to /usr/X11R6/lib/libX11.so.6.0 from
/usr/lib/libX11.so.3, but that didn't do anything.  The same problem
occurs also with stuff compiled on my machine, not just with precompiled
binaries--e.g. the "xmine"  game gives an identical message, except it
can't find "libXpm.so.4". 

Any ideas?  Why are all these programs looking in the same (wrong) places 
for their X libraries?

Alex Chamberlain

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-REQUEST@lists.debian.org . Trouble? e-mail to Bruce@Pixar.com

Reply to: