[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Who is guilty, the kernel or Debian?

Hello everyone,

I am writing this message while I am frustrated after fighting over and over
and over with a Debian 1.1 installation. This is my story:


cold start (reset switch or power cycle) Linux starts just fine; I can
compile the kernel, I can do networking (IPX, TCP/IP, SLIP, PPP, DNS, etc.),
I can do EVERYTHING... everything but rebooting: if I "shutdown -r +1&",
Ctrl-Alt-Del or "reboot" one of two things will happen:

1) After Linux does all the shutdown stuff (killing processes and unmounting
file systems) and just after the "Rebooting..." message is displayed on the
screen I will get some beeps generated by the BIOS. The number of beeps is
1-3-3 and according to the user's manual this means  "1st 64KB RAM chip or
data failure"

2) After the "Rebooting..." message is displayed, the computer seems to
reboot but the BIOS checks RAM and finds something wrong: I get a message
similar to "Memory failure at XXXX: expected YYYY and found ZZZZ - Please
run setup program."

I have found that sometimes I also get the error "CRC error" after Lilo
decompresses the kernel.

Known Facts

- Computer: Digital DECpc LPx 466d2 (genuine Intel 80486DX2 running at 66
MHz), 16 MBytes of RAM, and 128 KBytes of L2 cache. This computer has been
running Slackware 1.3 with kernel 1.2.13 for about one and a half year. It's
been a SMTP, WWW, POP3, and DNS server (dedicated) in a network of 50+ users
with no problems at all.

- Hard drive: first tried a 1.2 GBytes IDE hard drive, and after I started
to have problems (see above for a description of the problem), I switched
back to the original Digital hard drive (224 MBytes) - didn't help, I got
the same problems.

- Network card: BOCALANcard-VL (local bus a NE2100 compatible). I have used
always the lance.c driver.

- It seems the server is 100% stable (if I do not reboot)

- Debian 1.1. I have applied all upgrades in buzz-updates (up to Debian 1.1.14)

- Kernel: started with 2.0.6 and when I switched to 2.0.26 problems started.
I tried kernel from 2.0.20 and up and always got same problems.

What I have done

1) I have installed Debian 1.1 several times. First times using one of the
standard boot disks and the last time I built one custom boot disk (using
the boot-disks and kernel-package packages) - did not work.

2) I have installed Debian from two different sources: FTP (through
dpkg-ftp) and from SCSI CD-ROM. Did not work.

3) Recompiled the kernel from 2.0.20 and up and nothing good happened: if
there is a problem with the kernel, it is already present in 2.0.20. My next
move would be to try with the older kernel I have (2.0.7)

4) The first time I thought the problem was due to the fact that there is no
BIOS option to support LBA. Because of this I changed my 1.2 Gig. disk with
the one that came originally with the computer (a 224 Meg disk) I reinstall
Debian on it and the problem showed up again.

5) (I am not too sure I did this one) I disabled the secondary cache.


- I do not think the problem is hardware: again, this server ran Slackware
1.3 with kernel 1.2.13 for one and a half years. I DID NOT change anything
for Debian 1.1 and kernel 2.0.x.

- Something broken in the kernel.

- There is something wrong with the reboot program.

- I am using the new IDE driver. May be there is something wrong with it?


I am lost. I have installed Linux (Slackware and Debian) many times in
computers ranging from desktops to notebooks. I have used many kinds of
hardware (PCMCIA, SCSI, IDE, multiport serial boards) with Linux (Debian and
Slackware) and never had a problem.

I am posting this message here because I am a Debian user. However, I do not
know if the problem is Debian or the kernel.

This machine will be a very important part of our IT structure, it will get
rid of a FreeBSD machine, it will be the gateway between two networks
connected through a leased line and a dedicated PPP link. I can run the
machine the way it is now but then I won't be able to reboot remotely. I can
not go 4 blocks away every time I need to reboot the server. I NEED
STABILITY!!! (even at reboot time)

I want to know who is guilty: the kernel? Debian? Somebody else? I am
looking for help, support, new ideas, new clues, anything... PLEASE HELP!!!

Thank you very much Debian user.




Eloy A. Paris
Information Technology
Rockwell Automation de Venezuela
Telephone: +58-2-9432311 Fax: +58-2-9430323

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-REQUEST@lists.debian.org . Trouble? e-mail to Bruce@Pixar.com

Reply to: