[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: printing and .profile problems

At 11:19 PM 8/6/96 -0700, you wrote:
>Hi, I hope I'm doing this right. I tried to post to the linux.debian.user
>newsgroup without success.
>Anyway, I just installed Debian 1.1.2 in late July (my first Debian
>installation), with a few problems. I've fixed some of them thanks to this
>forum, but there are two among the many left that I'm trying to fix right now.
>1. dselect didn't configure lpr correctly so I did it myself using the
>printing HOWTO which I've done successfully many times before with Slackware
>releases. Now root can print but users get the message, "usr can't create
>/usr/spool/lpd/hp4p/.seq". This is with the permissions on that file set to
>rw_rw_r as the HOWTO says. I tried changing the permissions to rw_rw_rw but
>then a user gets the message "usr can't create
>/usr/spool/lpd/hp4p/tfA006Aa01777". As far as I know I have the permissions
>set correctly in all the directories leading to this file, but this seems
>like a permission problem. I'm stuck!
        Try this.... 
chmod 777 /usr/spool/lpd/hp4p/
         and then 
chmod u+t /usr/spool/lpd/hp4p/

                It sounds to me like lpr needs this area as a scratch pad
before printing.  Chmod u+t sets the sticky bit, which allows users to erase
only files they create.  This should clear up your problem, and if some Unix
guru out there noticed my syntax was wrong please point out to the world so
I don't make the same mistake myself ;>.


>Thanks in advance for any help.
>Chris Beamis

Reply to: