[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: MH/SMTP: No sending possible

--- Begin Message ---
Rob wrote:
>>>>> "M" == Michael Below <mbelow@hrz.Uni-Bielefeld.DE> writes:
> M> That's what I was trying to do, except that I wanted to fetch the
> M> mail via MH (inc -h <host>, according to the manpages).  smail is
> M> running really nice, I'm sending e.g. this mail using elm and
> M> smail. My problem was that in Debian, MH is configured to send its
> M> mail via smtp, and this didn't work (perhaps MH can't connect to a
> M> local smtpd?).
> I missed the first part of this thread, but if you're having trouble
> getting "inc -host" so work properly, it could be an authorization
> issue.  I messed with it for a while before realizing that I need the
> -noapop flag here.

Well, I didn't get that far.

I failed writing a local message and then decided to stay with elm, which 
does work.

My problem looked like this: After "comp"osing a mail, "post" didnt't deliver
it, it said something like "[BHST] Premature end of file on socket".
According to the FAQ, that means that post couldn't connect to the SMTP server.
(It looks like SMTP is the default with Debian MH).
I've tried to find out what might be missing, but I couldn't find it:
According to "netstat -a", the SMTPD (that seems to be another face of SMAIL)
is listening. It is in /etc/services and /etc/inetd.conf.

I tried adding a line like "servers: <my_host_name>" to /etc/mh/mtstailor
(maybe the path was /usr/bin/mh/mtstailor, I'm writing this from another 
machine...). That changed the error message to be something like "No servers

I would be interested in finding out if it was my fault or a bug -- what do
you think?

(I'm running the stable release, 0.93R6, with SMAIL as mail transport agent.
Everything else seems to work fine, I've already sent a number of messages
to this list using elm and SMAIL.)

Thanx in advance

--- End Message ---

Reply to: