[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

fdisk fails on a new pentium

Hi, all.

I've got one of Bruce's "Gold" CDs and I attempted to install Debian
from it for the first time on a friends machine that wanted to
check out Linux.  He has a rather new Intel PCI motherboard with
a 120 Mhz chip.  This board is one that has a lot of stuff integrated
on the mother board.  HD/FD/serial/parallel/game/mouse all on the
mother board.  The hard drive is a new Seagate 1.08 fast ata
drive.  It is the only hard drive and had previously been partitioned
by DOS 6.22 into 5 equal partitions.  I attemped to delete the
last partition and remake it into a couple of Linux partitions.
cfdisk (I think) is what the menu uses and all went well until
I tried to write the partition back out.  It hung the machine.
I rebooted and, sure enough, it didn't write anything out.  I then
tried to do it again, but I deleted the last DOS partition and 
created a small Linux partition at the beginning of the deleted
DOS partition.  It also hung the machine trying to write the partition
table.  I noticed that the powersaver features were turned on, so
the last time I repartioned, I did it real fast, so the disk wouldn't
power down.  I didn't know how well Debian would handle the disk
being powered down.

So I rebooted and got out of the menu and ran "fdisk".  Fdisk did
nothing.  It was as if I typed "cat".  I could see what I was typeing
but it never did anything.  I couldn't ^C out of it.  Nothing worked.

I then rebooted and brought up DOS and Windows.  They were working

Does anyone have a clue as to why I couldn't write the partition table
out?  Why did fdisk hang?


Jim Lynch, Sales Analyst,  Cray Research, Inc. / ARS: K4GVO
Southeast District, Phone: (770) 631-2254, Email: jwl@cray.com
Suite 270, 200 Westpark Drive, Peachtree City, GA 30269

Reply to: