[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian installation

On Mon, 29 Jan 1996, Shawn Asmussen wrote:

-------8<---Things I don't know-------8<------
> 	Before with slackware I was using Xfree 3.1.1, and everything was
> fine. Now, with 3.1.2 which is what debian has, X -probeonly blanks out 
> my screen with a little bit of white stuff in a pattern, and locks up my 
> machine. If I don't run X -probeonly, it just does the same thing when I try
> to startx. I had the same problem once when I tried to upgrade from 3.1.1 to
> 3.1.2 while still using Slackware, so I'm assuming that's where the problem
> is. My next idea is to put a small installation of Slackware back in 
> (Since I have it handy on CD, and it's got 3.1.1), and run X -probeonly, 
> and copy the clocks line that it generates, so that 3.1.2 hopefully never has
> to perform the probe that hangs the system. I'm using a generic ET4000/W32
> video card. Anybody know of something I should be doing differenly, or 
> anything?

I also use an ET4000/W32 and have similar problems. I tried the new
3.1.2B before going back to 3.1.1 and sent in this bug-report:

(hardware details ---8<---)


   With 3.1.1 the above hardware has no trouble whatsoever.
   But the textmode restore behaviour of W32 3.1.2 is downright
   flaky. Sometimes textmode is restored after leaving X, and
   sometimes it isn't. I haven't found a sequence that reliably
   leads to one thing or the other.
   3.1.2B can be thrusted to tell me it will expire in april before
   expiring immediately. Black screen: the thing actually puts the
   monitor on standby. Attempts to restart the monitor manually
   fail. On leaving X (^@-Bspc) the monitor awakes, but textmode
   fails to be restored.
I think doing a new probe with 3.1.1 won't do you any good. In any
case, you don't need a Slackware installation to do that: Just 
rename your present XF86_W32 (in /usr/X11/bin) to XF86_W32.312 or
something like that and copy your old XF86_W32 into its place.
Slackware keeps the thing in /slakware/x15/x312w32.tgz I think. You
can then do a probe if you want, but the information should already
be in your old XF86Config (You didn't throw it away, did you :). 
Use that and everything should be fine.  A further bit of renaming and
copying will allow you to test the 3.1.2 version. Prepare for a 
black screen, hope for the best...

Hope this helps a bit,

 #   sbolt@xs4all.nl   #   Steven Bolt   #   popular science monthly KIJK    #

Reply to: