[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ATAPI IDE CDROMS (sorry for yelling :-)

On Sat, 21 Oct 1995, Hunter H Marshall wrote:
> My basic comment is that I am able to access my Mitsumi CDROM without
> problem on a *custom* 1.2.13 kernel.  I could not with the generic 1.2.1

I have a similar experience with an NEC CDR271 ATAPI CDROM drive. It has
worked fine for me with custom-compiled 1.2.11, 1.2.12 and 1.2.13 kernels,
configured in the same way as Hunter showed. The drive is the "slave" on
my primary IDE controller, and at boot time the controller interrupt is
detected, the "master" (a Seagate HDD) is detected as /dev/hda, and the
CDROM is detected as /dev/hdb. I have iso9660 in /etc/modules, so the
filesystem support is also loaded at boot time. 

I don't know if it worked with the original Debian 1.2.1 kernel, I had to
replace that pretty quickly as I needed ne2000 support. However I believe
ATAPI support was included in the kernel tree late in the 1.1 series. As
Hunter said, it's presumably just a question of whether it was compiled

Incidentally, I also do a "make modules" and "make modules_install" when I
update the kernel, to update the modules as well (iso9660.o in
particular), though I don't know if that is always necessary. 


Reply to: