[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Sistema cracheado



Por que no haces todo con aptitude como primer consejo, luego revisa y si puedes postear tus repos seria mucho mejor, luego pegale una leida a los manuales del aptitude.

El 17 de febrero de 2010 18:37, David González Romero <dgr@dic.ohc.cu> escribió:
Hola Lista!!!

Tenía (tengo) un servidor Debian con la versión 4 (etch), ayer se me dio que
era el momento para realizar el dist-upgrade correspondiente, para
actualizarme a lenny. Hice mi busqueda en san google y encontré este manual
[1], el cual seguí al pie de la letra. Al llegar a la parte que decía:
# aptitude update apt aptitude
El sistema me devolvió un error, porque las ordenes update y upgrade no
necesitan argumentos. O sea esto no es complejo, seguí adelante y aquí empezó
toda la pesadilla.

Cuando hice un "aptitude dist-upgrade" el sistema comenzó el proceso de
actualización, se me hicieron preguntas, como desea instalar tal cosa que son
dependencias de tal otra... desea configurar esto o dejarlo para mas tarde...
desea reiniciar estos servicios... en fin a todo le fui dando las respuestas
necesarias, hasta que llegó un momento en que terminó dando un error que por
desgracia no llegué a copiar.

Bueno lo cierto es que aún poseo acceso al servidor, pero casi todo esta
detenido porque no puedo instalar las nuevas versiones, la herramienta
aptitude o apt-get me dan error cada vez que intento hacer algo. Primero me
dio este error:
/usr/bin/ucf: line 284: getopt: command not found

Hable con un amigo Debianita y me dijo que ese script era el que manipulaba
las configuraciones de los paquetes instalados y me envió el getopt por correo
de un servidor lenny que él tiene, lo puse en el lugar que debe ir, di los
permisos y propietarios necesarios y ahora el error es este:
Setting up bash-completion (20080705) ...
/usr/bin/ucf: line 284: /usr/bin/getopt: cannot execute binary file
dpkg: error processing bash-completion (--configure):
 subprocess post-installation script returned error exit status 126

Así con todos y cada uno de los paquetes que pone en una lista... Cualquier
cosa que haga con el aptitude o el apt-get sale esto, pero si intento irme a
mas bajo nivel con dpkg directamente haciendo un --configure me saca otro
error:
#dpkg --configure bash-completion
Setting up bash-completion (20080705) ...
/usr/bin/ucf: line 284: /usr/bin/getopt: cannot execute binary file
dpkg: error processing bash-completion (--configure):
 subprocess post-installation script returned error exit status 126
Errors were encountered while processing:
 bash-completion

Alguien me pudiera dar una manito al respecto... No soy muy ducho en Debian,
aunque si conozco linux en otras distros, pero creo que es un error
propiamente de la distribución...

Saludos,
David

1: http://www.guatewireless.org/os/linux/distros/debian/como-actualizar-de-
debian-4-etch-a-debian-50-lenny/




--
To UNSUBSCRIBE, email to debian-user-spanish-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 201002171837.39682.dgr@dic.ohc.cu" target="_blank">http://lists.debian.org/201002171837.39682.dgr@dic.ohc.cu



Reply to: