[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Fehlende ldconfig



Hallo nochmal,

also ich denke ich werde das System neu installieren.

Nichtsdestotrotz, gibt es irgendwo eine Seite wo man so prähistorische Pakete 
(z.B. in meinem Fall eine libc-bin die zur libc6 2.7-11 passt) herbekommt?

Viele Grüße,

Wolfgang

On Friday 21 August 2009 17:21:25 Wolfgang Pausch wrote:
> Hallo,
>
> ich hab mir gerade beim dist-upgrade eines lange nicht mehr updateten
> unstable-Systems ein ziemliches Problem eingehandelt:
>
> Stand vorher war ich hatte Kernel 2.6.15.  Gut, da hat mir dist-upgrade
> gesagt, wegen der libc6 müsse ich zuerst einen aktuellen Kernel
> installieren, und zwar mit dem Befehl apt-get install -t lenny
> linux-image-2.6.
> Dementsprechend habe ich die sources.list entsprechend ergänzt und das
> ausgeführt.  Bei der Ausführung dieses install inux-image-2.6-Befehls ist
> apt-get aber abgebrochen mit der Begründung ich hätte nicht erfüllte
> Abhängigkeiten.
>
> So, nach etwas rumprobieren habe ich mich dazu entschlossen so viele Pakete
> zu löschen bis ich um die Abhängigkeiten herum bin.  Das waren größtenteils
> dev-Pakete, darunter aber leider auch libc-bin.  Wie ich mittlerweile
> gelernt habe ist da ldconfig drin.  Eine besondere Warnung habe ich aber
> beim remove nicht bekommen, sonst hätte ich es gelassen ;-)
>
> So, jetzt stehe ich mit einem System ohne ldconfig da, bei dem insbesondere
> apt-get (anscheinend) keinen Befehl mehr ausführen kann.  Probeweise habe
> ich mal versucht die ldconfig aus dem libc-bin_2.9.25 nach /sbin zu
> kopieren, das funktioniert aber (wohl logischerweise) auch nicht, weil sie
> nicht zum Kernel passt.
>
> apt-cache policy libc6 sagt installed 2.7-11.
>
> Wie komm ich aus der Zwickmühle wieder raus?
>
> Danke für mögliche Hinweise und, falls das nicht sowieso üblich ist,
> versorgt mich bitte mit einem cc.
>
> Viele Grüße,
>
> Wolfgang



Reply to: