[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian IDE-Unterstüt zung (sarge)



Frank Lorenzen <fisch@Fh-Worms.de> wrote in message news:<2kRJR-46y-15@gated-at.bofh.it>...
> On Wed, Jul 21, 2004 at 11:11:55PM -0700, Alexander Mayer wrote:
> [...]
> > Folgende Module habe ich probiert zu laden /etc/modules
> > sis5513
> > ide-core
> > ide-disk
> > ide-cd
> > 
> > gateway:~# lsmod
> > Module                  Size  Used by    Not tainted
> > isofs                  27092   0  (autoclean)
>  [...]
> > ide-cd                 32128   0
> > cdrom                  28672   0  [ide-cd]
> > ide-disk               16736   0
> > sis5513                11568   0  (unused)
> > ide-core              109628   0  [ide-cd ide-disk sis5513]
>  [...]
> > 
> > Was muss ich denn nun für Module laden, dass ich das Lite-On IDE Atapi
> > Cd Laufwerk und die Western Digital IDE Festplatte ansprechen kann?
> > 
> > Anbei ein output von lspci
> > 
> > gateway:~# lspci
>  [...]
> > 0000:00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513
> > [IDE]
> [...]
> 
> 
> Das sieht doch eigentlich ganz gut aus. Was taucht unterhalb von
> /proc/ide auf?
> Falls dort dein CDrom (hdc) auftaucht, als Link auf ide1/hdc, wie
> _genau_ versuchst du zu mounten?
> 
Hallo,

jetzt hab ichs!
Unter Kernel 2.4 muss man das Modul "ide-detect" laden.
Dann klappts auch mit den ganzen IDE -Devices.

Unter Kernel 2.6 ist das Modul "ide-generic" gefragt.

Jetzt kann ich meine devices auch mounten!!

gruss

Alex

> > Auf einem zweiten Server habe ich das selbe Problem, ein IDE-Cdrom
> > Laufwerk
> > anzusprechen.
> > 
> > Anbei noch ein output der lspci von diesem Server.
> > filesrv:~# lspci
> > pcilib: Cannot open /sys/bus/pci/devices
> Darüber mußt du dir keine Gedanken machen, sysfs ist ein Feature von
> Kernel 2.6
> [...]
> > 0000:00:07.1 IDE interface: Advanced Micro Devices [AMD] AMD-768
> > [Opus] IDE (rev 04)
>  [...]
> > 
> > server:~# lsmod
> > Module                  Size  Used by    Tainted: P
> > isofs                  27416   0  (autoclean)
> [...]
> 
> Hier habe ich außer 'isofs' mal nichts relevantes für dein IDE-Cdrom
> entdecken können. Es war weder der amd-Treiber geladen, noch ide-cdrom.
> 
> > Bei jedem Kernel handelt es sich um Original debian initrd Kernel, die
> > ich per apt-get geholt habe. (apt-get install
> > kernel-image-2.4.26-1-k7...etc
> 
> Das schließt aus, daß du irgendwas am Kernel falsch gemacht hast.
> 
> > gruss
> > 
> > Alex
> 
> 
> gruss
> f



Reply to: