[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ViewCVS zeigt keine Dateien an



* Quoting Jens Lehmann <jens.lehmann@goldmail.de>:

>> Kann es sein, dass du kein CVS-Repository erstellt hast?
> 
> Das CVS-Repository liegt auf einem entsprechenden Server. Dort gibt es 
> jedoch kein Web-Frontend zur Betrachtung des Repositories (mit 
> Kommentaren, Diff etc.).

Dafür gibt es SandWeb, das auch SSH-Verbindungen zu entfernten Rep.
unterstützt, und für das es auch ein Debian-Paket gibt (mit dieser Zeile
in der sources.list: »deb http://sandweb.sourceforge.net/debian/ ./«).
Gefällt mir persönlich sehr gut.

> CVSROOT verweist auf diesen Server. Ich möchte 
> eine lokale Kopie des Repositories mit ViewCVS betrachten. Ich habe bis 
> jetzt ohne Probleme ein checkout ausgeführt und Dateien angelegt. Nach 
> Deinen Hinweisen reicht ein checkout jedoch nicht aus, weil dann noch 
> wichtige Kontrolldateien im Repository fehlen. Was muss ich zusätzlich 
> machen? Ich möchte eigentlich kein eigenes Repository erzeugen (wie Du 
> es beschrieben hast), sondern nur eine Kopie des Repositories haben.

Die Schritte, die ich beschrieben habe, sind AFAIK notwendig, um ein
gültiges Repository zu erzeugen (hast du die auf dem Server vorgenommen?).
Dann würde ich das Rep. per Kommandozeile auf den lok. Rechner kopieren
und das CVSROOT in /etc/viewcvs/viewcvs.conf entsprechend auf das
lokale Verzeichnis setzen.
Wenn du das schon so gemacht haben solltest, vermute ich, dass das Rep.
auf dem Server nicht vollständig gültig ist und daher von ViewCVS nicht
als solches erkannt wird ...


Gruß
Meinolf



Reply to: