[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Privoxy



Le 03/03/2014 21:44, Tito a écrit :
> On Mon, 3 Mar 2014 21:43:34 +0100
> Tito <tito@mailoo.org> wrote:
>
>> On Mon, 03 Mar 2014 21:23:36 +0100
>> Erwan David <erwan@rail.eu.org> wrote:
>>
>>> Le 03/03/2014 21:18, Tito a écrit :
>>>> root@debianwheezy:/home/tito# lsof -i:8118
>>>> COMMAND    PID       USER   FD   TYPE DEVICE SIZE/OFF NODE NAME
>>>> iceweasel 7490 tito   55u  IPv4  35885      0t0  TCP debianwheezy.home:36185->localhost:8118 (SYN_SENT)
>>>> iceweasel 7490 tito   56u  IPv4  35886      0t0  TCP debianwheezy.home:36186->localhost:8118 (SYN_SENT)
>>>>
>>>> Mon fichier interfaces et monté à la main, uns incidence possible?
>>>> :)
>>> Rien n'est en écoute dessus. Regarde la syntaxe de la configuration de
>>> privoxy pour voir si tu spécifie l'adresse d'écoute et le port comme il
>>> faut. Le message du log peut s'interpréter aussi comme si tu avait mis
>>> '127.0.0.1:8118' là où le soft attend juste une adresse (et attend son
>>> port ailleurs).
>> J'ai vérifié la config et j'ai bien :
>> listen-address  127.0.0.1:8118
>> J'ai déjà essayé de remplacer par localhost mais sans changement, y compris en renseignant localhost au lieu de 127.0.0.1 dans les préférences de iceweasel... Bref, je ne comprends pas. Iceweasel mouline sans établir de connexion avec le serveur distant... Si je choisis dans les paramètres de connexion d'iceweasel "detection automatique des paramètres de proxy" ou "utiliser les paramètres proxy du système", le surf revient mais rien n'est filtré par privoxy. 
>> Quand je choisis configuration manuelle du proxy, je renseigne le champ proxy http : 127.0.0.1 ou localhost (suivant si ma conf de privoxy et en 127.0.0.1 port 8118 ou en localhost port 8118), plus de surf possible (charegement éternel de la page).
>>
>> Et j'ai toujours ça:
>> root@debianwheezy:/home/tito# /etc/init.d/privoxy status
>> [FAIL] privoxy is not running ... failed!
>>
>> Vais-je devoir me tourner vers polipo? C'est dommage car j'avais un script pour privoxy qui me permettait, entre autre, d'ajouter le filtre de adblock (http://adblockplus.mozdev.org/easylist/easylist.txt)
>>
>> Qu'ais-je donc fait de mal :D
>> Merci.
Déjà ne lance pas iceweasel tant que ton privoxy ne tourne pas, ça ne
sers à rien.

En suite puisque 127.0.0.1:8118 est la valeur par défaut de
listen-address, retire le.

Vérifie que tu n'as pas 2 listen-address, par exemple.

PS: je ne connais pas privoxy j'ai juste jeté un coup d'œil à la doc.


Reply to: