[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [Fwd: Re: [Etait probleme X depuis maj du weekend ]]



djellel(deb) a écrit :

Le mardi 24 octobre 2006 16:54, BULOT Grégory a écrit :
djellel(deb) a écrit :
va dans /etc/X11
regarde si dans Xwrapper.config
nice_value=0
change  la valeur si ce n'est pas le cas ...
Profite-en pour regarder si le lien X pointe bien vers /usr/binXorg
j'ai mis 19 ...
X -> /bin/true

en changeant vers /usr/bin/Xorg, dans Xorg.0.log

[...]
(II) LoadModule: "vbe"
(II) Loading /usr/lib/xorg/modules/libvbe.so
(II) Module vbe: vendor="X.Org Foundation"
       compiled for 7.0.0, module version = 1.1.0
       ABI class: X.Org Video Driver, version 0.8
(II) LoadModule: "nvidia"
(WW) Warning, couldn't open module nvidia

(II) UnloadModule: "nvidia"
(EE) Failed to load module "nvidia" (module does not exist, 0)
installe "xserver-xorg-video-nv" en attendant que tu règles ton problème d'installation les pilotes propriétaires. change dans ton xorg.conf "nvidia" par "nv"
j'veux bien, mais je retourne à l situation initiale, ou il veux installer xserver-xorg-core (j'ai bien fait et vérifié que le dpkg -x xserver-xorg-core / ) qui plante avec ./usr/lib/xorg/modules/extensions/libglx.so
alors que stat /usr/lib/xorg/modules/extensions/libglx.so
 File: `/usr/lib/xorg/modules/extensions/libglx.so'
 Size: 439486          Blocks: 872        IO Block: 4096   fichier régulier
Device: 301h/769d       Inode: 375253      Links: 1
Access: (0644/-rw-r--r--)  Uid: (    0/    root)   Gid: (    0/    root)
Access: 2006-10-24 19:05:02.000000000 +0200
Modify: 2006-07-02 05:35:32.000000000 +0200
Change: 2006-10-24 19:05:03.000000000 +0200

(je rappel l'erreur :(Lecture de la base de données... 121414 fichiers et répertoires déjà installés.) Dépaquetage de xserver-xorg-core (à partir de xserver-xorg-core_1.0.2-9_i386.deb) ... dpkg : erreur de traitement de xserver-xorg-core_1.0.2-9_i386.deb (--install) : impossible de créer « ./usr/lib/xorg/modules/extensions/libglx.so »: Aucun fichier ou répertoire de ce type
dpkg-deb: sous-processus paste tué par le signal (Relais brisé (pipe))
Des erreurs ont été rencontrées pendant l'exécution :
xserver-xorg-core_1.0.2-9_i386.deb


apt-get -s install xserver-xorg-video-nv
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Les paquets supplémentaires suivants seront installés :
xserver-xorg-core xserver-xorg-input-all xserver-xorg-input-evdev xserver-xorg-input-kbd xserver-xorg-input-mouse
 xserver-xorg-input-synaptics xserver-xorg-input-wacom
Paquets suggérés :
 gsynaptics ksynaptics qsynaptics
Les NOUVEAUX paquets suivants seront installés :
xserver-xorg-core xserver-xorg-input-all xserver-xorg-input-evdev xserver-xorg-input-kbd xserver-xorg-input-mouse xserver-xorg-input-synaptics xserver-xorg-input-wacom xserver-xorg-video-nv
0 mis à jour, 8 nouvellement installés, 0 à enlever et 6 non mis à jour.
Inst xserver-xorg-video-nv (1:1.0.1.5-2 Debian:testing) []
Inst xserver-xorg-input-evdev (1:1.1.2-3 Debian:testing) []
Inst xserver-xorg-input-kbd (1:1.0.1.3-2 Debian:testing) []
Inst xserver-xorg-input-mouse (1:1.0.4-3 Debian:testing) []
Inst xserver-xorg-input-synaptics (0.14.6-1 Debian:testing) []
Inst xserver-xorg-input-wacom (0.7.4.1-5 Debian:testing) []
Inst xserver-xorg-input-all (1:7.0.22 Debian:testing) []
Inst xserver-xorg-core (1:1.0.2-9 Debian:testing)
Conf xserver-xorg-input-evdev (1:1.1.2-3 Debian:testing)
Conf xserver-xorg-input-kbd (1:1.0.1.3-2 Debian:testing)
Conf xserver-xorg-input-mouse (1:1.0.4-3 Debian:testing)
Conf xserver-xorg-input-synaptics (0.14.6-1 Debian:testing)
Conf xserver-xorg-input-wacom (0.7.4.1-5 Debian:testing)
Conf xserver-xorg-input-all (1:7.0.22 Debian:testing)
Conf xserver-xorg-core (1:1.0.2-9 Debian:testing)
Conf xserver-xorg-video-nv (1:1.0.1.5-2 Debian:testing)

les autres concernant les périphériques génére le même resultt si je veux les installer


Bien normal que t'ais un 'blème puisque tu dois compiler et installer des modules quand installes tes pilotes nvidia. .. il faut installer les sources correspondant exactement à ton noyau ou/et les entétes de ton noyau et tout le nécessaire pour compiler un programme et installer les modules. un apt-get install kernel-source-$(uname -r) devrait faire l'affaire je crois!... tout le reste viendra avec!... je croise les doigts! :)
c'est ptet plutôt linux-source plutôt (ça j'avais vaguement souvenir qu'il y avait eu un changement)

le truc marrant :
uname -r
2.6.17-2-k7
apt-get -s install  linux-source* | grep 2.6.17
Note, sélectionne linux-source-2.6.17 pour l'expression rationnelle « linux-source* »
 linux-source-2.6.16 linux-source-2.6.17
 linux-source-2.6.16 linux-source-2.6.17
Inst linux-source-2.6.17 (2.6.17-9 Debian:testing)
Conf linux-source-2.6.17 (2.6.17-9 Debian:testing)



Reply to: