[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: BLAS and LAPACK in Ubuntu


Sam Halliday <sam.halliday@gmail.com> writes:

> Hello,
> I'm currently liaising with the author of F2J (Fortran to Java) to
> create a JNI (Java Native Interface) so that it is possible to call
> the BLAS/LAPACK libraries directly from within Java.
> Work on this has almost finished... however, most of the LAPACK
> community has now moved onto LAPACK-3.1 and Ubuntu are still using
> LAPACK-3.0. In order to cater to the lowest common denominator, this
> is forcing me to exclude JNI support to all the new functions on all
> operating systems.
> I was wondering if you could please update the version of LAPACK in
> Ubuntu Gutsy to 3.1 so that I can remove this restriction on my
> package.
> Thanks and kind regards,

This is currently in progress.  I had decided to get the gfortran
transition in first, but there appear to be portability issues which
might take a reasonable time to fix.  I suppose a separate lapack3.1
is in order while this is worked out.

Take care,

> -- 
> Sam
> http://fommil.me.uk
> http://javablog.co.uk

Camm Maguire			     			camm@enhanced.com
"The earth is but one country, and mankind its citizens."  --  Baha'u'llah

Reply to: