[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: unable to install (upgrade) git - git-man dependency

Hi Riccardo,

On 23.11.22 17:23, Riccardo Mottola wrote:
let's see how 6.0 will fare for you.

I did try to mount nfs v3 on my system and it worked, I did a classic
mount with mount.nfs once booted. Mount works and I was able list and to
touch and remove a file. I did not try further because I didn't set up
permission properly, could do though.

Is this significative for you or is your issue NFS mount within kernel
for NFS boot and that goes through another path?

Not necessarily but I think we can conclude from this, that my T1000
might work with an initramfs build by dracut as it does not use klibc
based tools but glibc based ones ([1]) - which work as you showed above.
Standard initramfs-tools use klibc ([2]).

[1]: https://packages.debian.org/sid/dracut-core

[2]: https://packages.debian.org/sid/initramfs-tools-core

Something is bad with klibc since a while - for the DHCP case actually
since I tried for the first time years ago - on e.g. UltraSPARC T1 and
III(i) which breaks IP autoconfiguration with DHCP and NFS mounts from
within the initramfs. That's why I need to use a kernel comand line with
IP address information (+ NFS server address) hardcoded to get it going:

nfsroot= nfsrootdebug rw

...which is good enough for my purposes. Not been able to mount the NFS
root FS is unfortunately not. :-(

I will see for myself when I get to try Linux 6.x on my gear.


Reply to: