[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian/SPARC[64]

On 01/14/15 09:18 AM, Mark Cave-Ayland wrote:
On 14/01/15 06:34, Karel Gardas wrote:

On 01/13/15 10:24 AM, Mark Cave-Ayland wrote:
On 12/01/15 15:12, Karel Gardas wrote:

Hi Mark,

it's great that you mention this. Indeed, for Solaris 11 I'm using
T2000, for sparc/sparc64-linux (Debian 7.x) I've decided to give a try
to Qemu 2.2 SPARC64 emulation. First time I've not been lucky with
network (ne2k-pci not working) but later after some googling I've found
that virtio is working.

Hmmm I've previously run through the entire Debian installer using the
in-built QEMU userspace network stack and have successfully managed to
detect an rtl8029 network card and get a valid DHCP lease? What appears
to be the problem?

The network was not working at all. For debian I've solved that by using
virtio. For OpenBSD 5.6 I've solved that by using i82551.

Okay so now I am really confused. The ne2k/rt8029 networking here works
out of the box, definitely for both a NetBSD 6.1.x SPARC64 guest and my
Debian wheezy SPARC64 guest. I've also had reports of this working from
other people with and without virtio, with both NetBSD and Debian Linux

Can you clarify your host setup and the exact command-line used to
launch QEMU 2.2? Here I'm using Debian wheezy amd64 host OS with a 3.15
kernel. The command line is based upon booting from the netinst ISO
image like this:

qemu-system-sparc64 -cdrom debian-7.7.0-sparc-netinst.iso -boot d -nographic

Yes, with this command line it was not working. I remember I've seen ne2k-pci in dmesg, I also see (ifconfig) that it gets IP. The problem was that I've not been able to reach any remote side nor Solaris 11 host. With this:

$HOME/sfw/qemu-2.2.0/bin/qemu-system-sparc64 -hda debian.img -nographic -m 1024 -net nic,model=virtio -net user

it was running fine. ANy host tested reachable. Honestly the problem with networking may be in the platform I've been using. And that is:

amd64 + Solaris 11, inside it running VirtualBox 4.3.16 with Ubuntu 14.04 LTS on AMD64 and inside it Qemu 2.2.

Later I've been able to compile Qemu 2.2 on Solaris 11 so OpenBSD was run directly on Solaris 11/AMD64 + Qemu 2.2. This time neither ne2k-pci was working so I switched to i82551.

So it may be a little bit confusing, but as networking is running well now, I would consider this to be low priority...

If you continue through the installer then requesting a DHCP lease as
part of the installation works as normal. And also please double-check
that you are definitely running your new 2.2 installation and not
another version supplied with your OS.

Yes, in both cases I run qemu 2.2.


Reply to: