[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can't use all of my disk in my SS20.


With regard to the Etch install, I installed Sarge, which was fine.  i then did a dist-upgrade to Etch.

Previously, I had been getting "File does not appear to be executable", on my first reboot.  I had a bit of a long-shot and installed debian on my 2nd HDD.  My two disks were labelled something like disk 0 and 1, when I picked where to install debian.  I was making the mistake of thinking that the default boot was disk 0.  I was wrong.  When I installed on the 2nd disk, everything worked just fine.  Hence my install of Etch, which is just finishing.

With regard to the second part of your message, copying the disk geometry etc, yo totally lost me, I'm afraid.

Hope this helps the archive.



On 18/07/07, Martin <inkubus@interalpha.co.uk> wrote:
On Wed, 2007-07-18 at 16:13 +0100, Chris Andrew wrote:
> Hi, all.
> I have succesfully installed Etch on my SS20.  I have 2 harddrives,
> both 2.1Gb.
Given the previous problems, it might be nice (for the archives) to
explain how you did it.

> The first HDD will only let me use 200 megs of it.  I have tried all
> sorts of formatting, but it just won't let me touch most of the drive.
> When I do fdisk /dev/sdb, it just shows the two partitions that I have
> created, plus the Sun "whole disk" partition.  I still can't do
> anything with almost 2 gigs of HDD.  Can anyone tell me how I can get
> around this?
Is this a problem with disk labels?  Some partition tools require
builiding a Sun disk label which includes the number of heads,
cylinders, etc.  Some of this information is then used by Linux.  Copy
and data to the other disk, zero the start of the disk and then use
something like fdisk which (IIRC) will create a Sun disk label.


- Martin

To UNSUBSCRIBE, email to debian-sparc-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: