[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian Etch on SunFire V880

On my SunFire v440 I had a Solaris 9 installation running well with 4 CPU modules. With Debian it seems it indicated one as faulty, and I had to remove at least one module for Debian to work well. Although it bugged out earlier for me, already during initial boot, until I removed one module... Perhaps the error below is an indication of something similar, it could be an idea to strip the 880 down to a minimum config and start from there ? I have a severe case of rookieness with Sparc and Debian, but if I'm not mistaken the Cheetah is the name of the CPU, and the 880 can have up to 8 of them ?

Morgan Walker skrev:
I am using strictly the serial port for this installation.  Everything
gets displayed via the serial port.  However, when I had the console and
serial port connected, something similar to what you described did

Ok, so I tried to netboot using a 2.6-18 boot.img and attached the
output which I received.  Does anybody know what this means?

-----Original Message-----
From: Per Larsson [mailto:per.larsson@bahnhof.se] Sent: Wednesday, March 07, 2007 2:16 AM
To: Debian Sparc
Subject: Re: Debian Etch on SunFire V880

Martin skrev:
On Tue, 2007-03-06 at 14:56 -0500, Morgan Walker wrote:
I am at a total loss.

I am trying to install debian etch 3.1r5 netinst .iso on a SunFire
w/ OBP version 4.18.2, scsi drives, and 4G of memory via serial
console.  Every time it gets to "Booting Linux..." it appears to hang
is just throwing the output somewhere else.
Silly question but have you checked whether it's using the serial port
for output?  IIRC some systems, where the OpenBoot console is set to
default to serial port, it will print 'Booting Linux' on the console
(and even run OpenBoot on the console if you use the keyboard to
initiate it) and then output on the serial port.  Perhaps I'm mistaken
it was a while ago and on a much older system.

 - Martin

I had issues with my v440 until I tried the "daily build" netinstall image found here:
Not sure if that will help in your case, but something to try perhaps ?


net boot^H ^H^H ^H^H ^H^H ^H^H ^H^H ^H^H ^H^H ^Hboot net:dhcp -p
Resetting ...

Software Reset

Enabling system bus....... Done
Initializing CPUs......... Done
Initializing boot memory.. Done
Initializing OpenBoot
^QProbing system devices
Probing I/O buses
Probing system devices
Probing I/O buses

Sun Fire 880, No Keyboard
Copyright 2005 Sun Microsystems, Inc.  All rights reserved.
OpenBoot 4.18.2, 8192 MB memory installed, Serial #57216562.
Ethernet address 0:3:ba:69:e:32, Host ID: 83690e32.

Initializing    12MB of memory at addr        b0ff000000 -^H                                                                      I$
Rebooting with command: boot net:dhcp -p
Boot device: /pci@9,700000/network@1,1:dhcp  File and args: -p
PROMLIB: Sun IEEE Boot Prom 'OBP 4.18.2 2005/06/30 07:53'
PROMLIB: Root node compatible:
Linux version 2.6.17-2-sparc64 (Debian 2.6.17-9) (waldi@debian.org) (gcc version 4.1.2 20060901 (prerelease) (Debian 4.1.1-13)) #1 $
Ethernet address: 00:03:ba:69:0e:32
Remapping the kernel... done.
Booting Linux...
CPU[0]: Caches D[sz(65536):line_sz(32)] I[sz(32768):line_sz(32)] E[sz(8388608):line_sz(512)]
Built 1 zonelists
Kernel command line: -p
PID hash table entries: 4096 (order: 12, 32768 bytes)
Console: colour dummy device 80x25
Dentry cache hash table entries: 1048576 (order: 10, 8388608 bytes)
Inode-cache hash table entries: 524288 (order: 9, 4194304 bytes)
Memory: 8306520k available (2152k kernel code, 720k data, 144k init) [fffff80000000000,000000b0ffb0e000]
Calibrating delay using timer specific routine.. 20.00 BogoMIPS (lpj=40005)
Security Framework v1.0.0 initialized
SELinux:  Disabled at boot.
Capability LSM initialized
Mount-cache hash table entries: 512
checking if image is initramfs... it is
Freeing initrd memory: 2796k freed
NET: Registered protocol family 16
PCI: Probing for controllers.
SCHIZO0 PBMB: ver[7:0], portid 8, cregs[40004400000] pregs[40004700000]
SCHIZO0 PBMB: PCI CFG[7ffee000000] IO[7ffef000000] MEM[7fe00000000]
SCHIZO0 PBMA: ver[7:0], portid 8, cregs[40004400000] pregs[40004600000]
SCHIZO0 PBMA: PCI CFG[7ffec000000] IO[7ffed000000] MEM[7fd00000000]
SCHIZO1 PBMB: ver[7:0], portid 9, cregs[40004c00000] pregs[40004f00000]
SCHIZO1 PBMB: PCI CFG[7ffea000000] IO[7ffeb000000] MEM[7fc00000000]
SCHIZO1 PBMA: ver[7:0], portid 9, cregs[40004c00000] pregs[40004e00000]
SCHIZO1 PBMA: PCI CFG[7ffe8000000] IO[7ffe9000000] MEM[7fb00000000]
PCI-IRQ: Routing bus[ 0] slot[ 1] to INO[1d]
PCI-IRQ: Routing bus[ 0] slot[ 1] to INO[1f]
PCI1(PBMB): Bus running at 33MHz
PCI1(PBMA): Bus running at 66MHz
PCI-IRQ: Routing bus[ 0] slot[ 1] to INO[1c]
PCI-IRQ: Routing bus[ 0] slot[ 5] to INO[18]
PCI0(PBMB): Bus running at 33MHz
PCI-IRQ: Routing bus[ 0] slot[ 1] to INO[00]
PCI-IRQ: Routing bus[ 0] slot[ 2] to INO[04]
PCI0(PBMA): Bus running at 66MHz
ebus0: [flashprom] [bbc] [power] [i2c -> (fru) (fru) (fru) (fru) (fru) (fru) (fru) (fru) (fru) (fru) (fru) (fru) (fru) (fru) (fru) $
power: Control reg at 000007fc7e30002e ... not using powerd.
usbcore: registered new driver usbfs
usbcore: registered new driver hub
NET: Registered protocol family 2
IP route cache hash table entries: 262144 (order: 8, 2097152 bytes)
TCP established hash table entries: 1048576 (order: 10, 8388608 bytes)
TCP bind hash table entries: 65536 (order: 6, 524288 bytes)
TCP: Hash tables configured (established 1048576 bind 65536)
TCP reno registered
chmc0: US3 memory controller at 0000040000400000 [ACTIVE]
chmc1: US3 memory controller at 0000040000c00000 [ACTIVE]
chmc2: US3 memory controller at 0000040001400000 [ACTIVE]
ERROR(0): Cheetah error trap taken afsr[0010100000000000] afar[0000040001c00000] TL1(0)
ERROR(0): TPC[424d68] TNPC[424d6c] O7[6e2c30] TSTATE[80001606]
ERROR(0): M_SYND(0),  E_SYND(0), Privileged
ERROR(0): Highest priority error (0000100000000000) "Unmapped error from system bus"
ERROR(0): D-cache idx[0] tag[0000000000000000] utag[0000000000000000] stag[0000000000000000]
ERROR(0): D-cache data0[0000000000000000] data1[0000000000000000] data2[0000000000000000] data3[0000000000000000]
ERROR(0): I-cache idx[0] tag[0000000000000000] utag[0000000000000000] stag[0000000000000000] u[0000000000000000] l[0000000000000000]
ERROR(0): I-cache INSN0[0000000000000000] INSN1[0000000000000000] INSN2[0000000000000000] INSN3[0000000000000000]
ERROR(0): I-cache INSN4[0000000000000000] INSN5[0000000000000000] INSN6[0000000000000000] INSN7[0000000000000000]
ERROR(0): E-cache idx[0] tag[0000000000000000]
ERROR(0): E-cache data0[0000000000000000] data1[0000000000000000] data2[0000000000000000] data3[0000000000000000]
Kernel panic - not syncing: Irrecoverable deferred error trap.

 <0>Press Stop-A (L1-A) to return to the boot prom

No virus found in this incoming message.
Checked by AVG Free Edition.
Version: 7.5.446 / Virus Database: 268.18.7/712 - Release Date: 2007-03-06 15:42

Reply to: