[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problems with an Ultra 5

I was unable to get a null modem cable working, hooked up to a linux box, trying both minicom, and uucp's cu... I would really love to get this option working, does it need to be enabled by a jumper on the mainboard, or in the OBP settings somewhere? Anyone have any OBP documentation? Suns site seems to want a service contract for anything useful on their site.

I did however, get another monitor hooked up that supports the higher resolution (what a pita that 1024x768 doesn't work), and low and behold, the system comes to life, and trys to boot a copy of solaris 5.8. I haven't actually followed through to see if the solaris does anything, as I'm not really interested in that right now. I'm more interested in getting debian onto the computer. The OBP open boot prom version is 3.25 if it matters, and I now get the same messages as "Pooly" on the list is getting.. it gets to the Ram disk, and fails with the messages:

RAMDISK   : Couldn't find valid RAM disk image starting at 0
Freeing initrd memory 2970k freed
cramfs: wrong magic
Kernel Panic: VFS: Unable to mount root fs
Press L1-A (STOP + A on newer keyboards I found) to return to the boot prom on 00:00

So I then go into boot prom, and type boot cdrom again to reboot and try another option. I tried "linux ramdisk_size=16000", and it came up with the same error.

As someone may have mentioned in another thread in the last few weeks, maybe there's a snapshot of the netboot install cd that may work better on an ultra 5? Can someone point me to it, or tell me which one, and how to get it.


PS: I'd really like to get the serial console working as well if anyone knows how to troubleshoot that bit... I tried disconnecting the keyboard, tried both Serial A and Serial B (does only A work when serial console DOES work, or is B okay to use on an ultra5 as well?).

Tyler wrote:

I will give it a try if STOP + A, and serial console gives me nothing when I try tonight.


Robert Wolfe, OpenSource Solutions wrote:

On Fri, 05 Aug 2005 01:44:19 -0700
Tyler <pml@dtbb.net> wrote:

I'm trying to set up an Ultra 5 that I purchased last year, but am having problems getting anything out of it. I've hooked it up to power, network, video and sun type 6 keyboard/mouse (not usb). I've then turned it on, a few seconds goes by with the monitor not doing anything, then, the monitor gets a signal, and comes out of power save mode, but this only lasts 5 or 10 seconds, before it goes back to power save mode (no signal) (and never gets a signal again), so this isn't long enough to see anything on the screen because the screen isn't on long enough (doesn't warm up) to actually see the image.

The system sounds like its doing something still, as the 8.4gb IDE hard drive chugs away for 30 seconds to a minute, before becoming quiet again. At this point.. I don't know what (if anything) I can do .. without rebooting it again (is there a key combo for rebooting?). I've tried turning it on with a debian sarge net install bootable CD, and a solaris 9 install cd, both do the same thing as above.

At this point, I'm looking for help (documentation) on setting up, and troubleshooting an ultra5/10 system, lists of key combinations that may help me (I've read that STOP + A during power on may get me to the OBP open boot prompt, however, I haven't had the chance to try this option yet, and am not really sure what settings may need changing once i'm there, to stop the video from disabling itself, or whatever its doing).

You might want to try a monitor that supports a higher resolution. I had this same problem when I first got my Ultra 5. I placed a KDS X-Flat monitor and it works great.

Reply to: