[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: Debian on Sparc 4 - woody to sarge - some progress

I was too eager ... thanks Jurij, I tried modprobe sunlance.o instead of
just sunlance.  I was kinda getting into the right general idea but led
myself astray a bit it seems.

modprobe sunlance worked just fine.

I shall have a good look around to see if there are any other modules
which should be listed in /etc/modules as I certainly missed that.

Now the question is this, as the interface issue will be cleared up on
reboot, the error I experienced when I rebooted the new kernel: -

VFS: Disk quotas vdquot_6.5.1
devfs: v1.12c (20020818) Richard Gooch (rgooch@atnf.csiro.au)
devfs: boot_options 0x0
Console: switching to mono PROM 80x34
pty: 256 Unix98 ptys configured
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
RAMDISK driver initialized: 16 RAM disks of 812K size 1024 blocksize
Initializing Cryptographic API
NET4: Linux TCP/IP 1.0 for NET4.0
IP: routing cache hash table of 512 buckets, 4Kbytes
TCP: Hash tables configured (established 4096 bind 8192)
NET4: Unix domian sockets 1.0/SMP for Linux NET4.0.
VFS: Cannot open root device "sda1" or 08:01
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on 08:01
  Press L1-A to return to the boot prom

Was that a user issue because I have symlinks in / pointing to /boot and
_also_ have the following silo.conf file?  I still had the Please append
a correct "root=" boot option even though it is clearly in my silo.conf

$ cat /etc/silo.conf



Getting there slowly but surely.  I am still reluctant to reboot just
yet as I would like to minimize fallout.



-----Original Message-----
From: Jurij Smakov [mailto:jurij@wooyd.org] 
Sent: 01 July 2005 23:58
To: Steve Lewis
Cc: debian-sparc@lists.debian.org
Subject: Re: Debian on Sparc 4 - woody to sarge - some progress

On Fri, 1 Jul 2005, Patrick Morris wrote:

> Have you tried "modprobe sunhme" ?
> On Fri, 01 Jul 2005, Steve Lewis wrote:
>> I see under the /lib/module/2.2.x directory there is no sunhme.o, yet

>> there is under /lib/modules/2.4.x/kernel/drivers/net ... doesn't 
>> sunhme.o take care of my eth0 interface? ... or not as the case maybe

Yes, the network card drivers used to be compiled into the kernel in 
2.2.20, but are available as modules in 2.4. From previous postings it
clear that you have a Sun Lance network card, so the command to activate

it should be 'modprobe sunlance', not sunhme. You can also add the name
the module (sunlance, that is) to /etc/modules, so it is automatically 
loaded on every boot.

Best regards,

Jurij Smakov                                        jurij@wooyd.org
Key: http://www.wooyd.org/pgpkey/                   KeyID: C99E03CC

To UNSUBSCRIBE, email to debian-sparc-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact

Reply to: