[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Trouble with upgrade to unstable on SS20 SMP

I had Woody running on this thing for a while, and recently decided to upgrade to unstable (new QFE card - want iptables for a router/Squid box). I am having a bit of a problem, though - doing apt-get dist-upgrade fails, saying that due to my CPU, libc6 (= 2.3.2.ds1-13) needs kernel 2.4.21 or greater.

Okay, so I apt-get install kernel-image-2.4-sparc32-smp, and get unmet dependency warnings on libc6 (2.2.5-11.5).

I am stuck - can't upgrade the kernel w/o libc, can't upgrade libc w/o the kernel. Something appears to be broken in the dist-upgrade system - either that, or my machine has something screwy about it.

2xTI SuperSparc 50's (per /proc/cpuinfo), maybe?

Is there a way to shoehorn unstable on this without running headlong into dependency hell? I mean, short of compiling a kernel on my Sparc (ZZZZZzzzzz....) is there some magic switch or command I overlooked to just make it work?

Reply to: