[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problems with quad ethernet on Ultra 1

We've got a number of Ultra 1s with quad ethernet sbus cards using the
sunqe module.  Kernels are all 2.4 stock, some from Debian, one pristine
2.4.24.  We get regular kernel messages like

Mar 14 08:47:35 davison kernel: eth2: Babble error.


Mar 14 11:16:09 davison kernel: eth2: Receive packet dropped.

for each of the interfaces, especially the ones handling a lot of
traffic (the main machine that uses its quad ethernet card is a
firewall).  Look at the stats with ifconfig,

          RX packets:157597723 errors:2707 dropped:806 overruns:0 frame:2304
          TX packets:186807608 errors:7375842 dropped:0 overruns:0 carrier:3297
          collisions:7372545 txqueuelen:1000 
          RX bytes:68340018054 (63.6 GiB)  TX bytes:81840023303 (76.2 GiB)

shows that over the fairly long period the machine has been up, there
have been enough errors to wonder what's going on.  The cables appear to
be good, even when check with a proper cable tester; one connected
to an IA32 machine shows no errors whatsoever on the other end (even
when it was directly connected).

The other, possibly related, oddity is that when bringing up the
interfaces (after loading the sunqe module without incident), we get
messages like 

Mar 17 13:17:04 ace kernel: SYSIO[1f]: size[0] MID[0]
Mar 17 13:17:04 ace kernel: SYSIO[1f]: AFAR[000001ff0001000f]
Mar 17 13:17:04 ace kernel: SYSIO[1f]: Secondary SBUS errors [(none)]

with no obvious meaning.

Has anyone else seen this kind of problem?  Does anyone know what to do
about it?

Brian Campbell

Reply to: