[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: FTBFS question on sparc

On Thu, Mar 18, 2004 at 10:44:35AM -0800, Paul Telford wrote:
> >> 
> >> So I assume I just need --disable-libsuffix?
> >
> > Yep, sounds like the culprit.
> No dice.  Strange thing is that the package successfully configures in the
> sid chroot on vore.d.o both with and without the disable-libsuffix flag,
> so there must be something different about the sbuild environment.  
> Anyone here willing to try building on sparc so I can get a second
> opinion?  I don't have direct access to a sparc machine myself and there
> are a number of build-depends which I can't easily install on the
> developer machine.  Package is 'digikam' -- a copy of the config.log would
> help me out a lot.  I hate to keep uploading minor package changes just to 
> debug.

I just tried to compile it, and it doesn't work. First, as you found,
you need to have the "--disable-libsuffix". But it still doesn't compile
because it can't find the libXt (you can see this error on :

I needed to add a LDFLAGS line in debian/rules :
  export LDFLAGS +=-L/usr/X11R6/lib

Now it's compiling ... not finished yet !

Thomas Poindessous

Reply to: