[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Installation of Debian 3.0.23 hangs on Sun Netra t1

Hello everyone,

I'm relatively new to Linux installations on Sun machines but I can't get
Debian 3.0.23 running
on my Sun Netra t1 105. I tried it hard for a couple of days now - googled
the web and scanned
forums, mailing list etc., but couldn't get a solution. I also don't know
if this is the correct place to
put this.

However, simply said, the installation of Debian 3.0.23 hangs after a
unpredictable time
when trying to install the Base System.

Hereafter, you can see a detailed description of what I've done and what
Fresh start
Installation of woody sparc 3.0.23-2002-05-21

via LOM port A on Sun Netra and a Hyperterminal telnet client connected
via COM1 (9600Baud) running on an IBM ThinkPad T30.

I followd the install instructions step by step, except that I added the
mountpoints as stated below before proceeding to the kernel installation

Here is the partition table I used:
Note: The system was previously partitioned and setup with Sun Solaris.
disk /dev/sda (Sun disk label): 27 heads, 133 sectors, 4924 cylinders
Units = cylinders of 3591 * 512 bytes

   Device Flag    Start       End    Blocks   Id  System
/dev/sda1   r         0        11     19750+  83  Linux native
/dev/sda2  ur        11       524    921091+  83  Linux native
/dev/sda3   r       524      1949   2558587+  83  Linux native
/dev/sda4   r      1949      3089   2046870   83  Linux native
/dev/sda5   r      3089      3545    818748   83  Linux native
/dev/sda6   r      3545      4685   2046870   83  Linux native
/dev/sda7  ur      4685      4830    260347+  82  Linux swap

Command (m for help):

Disk /dev/sdb (Sun disk label): 27 heads, 133 sectors, 4924 cylinders
Units = cylinders of 3591 * 512 bytes

   Device Flag    Start       End    Blocks   Id  System
/dev/sdb1   r         0      1140   2046870   83  Linux native

Command (m for help):

sda1 = boot 20  MB
sda2 = root 900 MB
sda3 = usr  2.5 GB
sda4 = opt  2.0 GB
sda5 = tmp  800 MB
sda6 = home 2.0 GB
sda7 = swap 255 MB
sab1 = var  2.0 GB

Note: What confused me was that when writing the partitiontable to the
disks, the installation routine wrote something abot 'Synching disks'
I did't understand this and ignored it. Does this somehow have to do with
a RAID or such?

Behaviour after repartitioning and rebooting:

Netra t1 (UltraSPARC-IIi 440MHz), No Keyboard
OpenBoot 3.10.24 ME, 256 MB memory installed, Serial #12713262.
Ethernet address 8:0:20:c1:fd:2e, Host ID: 80c1fd2e.

Executing last command: boot
Can't read disk label.
Can't open disk label package
Boot device: disk1  File and args:
Warning: Fcode sequence resulted in a net stack depth change of 1
The file just loaded does not appear to be executable.

then I rebooted the machine with the CDRom and continued the

Parameter settings I took while installing:

- ethernet NIC connected to eth0
- no domainname
- no BOOTP or DHCP
- fixed IP-address
- Networkmask
- fixed gateway
- 2 DNS server IP addresses

everything else I took the recommended suggestions of the installation
Modules additionally installed:

- Installing module ppp_generic. If the device isn't there, or isn't
configured co
rrectly, this could cause your system to pause for up to a minute.

Installation succeeded.

- Installing module sg. If the device isn't there, or isn't configured
this could cause your system to pause for up to a minute.

Installation succeeded.

Note: I also tried an installation without these oprions with the same
Also note: The installation of the kernel modules took quite long, like 2
Is this normal?

Then I proceeded to the Base System installation:
- First this error came:
cannot create /proc/sys/kernel/modprobe: directrory nonexistent

And after a while this screen was shown:
cannot create /proc/sys/kernel/modprobe: directory nonexistent

         ³                                                            ³
         ³ The installation program is building a list of all         ³
         ³ directories containing a file                              ³
         ³ 'dists/woody/main/binary-sparc/Release' or 'basedebs.tar'  ³
         ³ that can be used to install the Base system.               ³

This screen never changed again, but I could observer the CDRom was running
and working. So the system must have done something.

After like 3.5 hours the system seems to be hanging
Waited for like another 2-3 hours; cdrom didn't do anything anymore and
the screen was left as shown above. The installation routine didn't
response on any keystroke anymore. So I gave it up and turned the machine
off. And tried to re-run the Base System installation over the already
existing (and obviously not working and correct) version.
I observed a similar behaviour and this time the system hung in the screen
shown below after approximately the same time...


   ³ Installing base packages...


Additionally I attch the boot-output when booting via the installation
CD-ROM, if it helps

******************** BOOT OUTOUT ************************
boot: rescue
Loading initial ramdisk....

Remapping the kernel... done.
Booting Linux...
PROMLIB: Sun IEEE Boot Prom 3.10.24 1999/08/16 17:37
Linux version 2.4.18 (root@vore) (gcc version egcs-2.92.11 19980921 (gcc2
609 experimental)) #2 Thu Apr 11 14:37:17 EDT 2002
Ethernet address: 08:00:20:c1:fd:2e
On node 0 totalpages: 32040
zone(0): 89950 pages.
zone(1): 0 pages.
zone(2): 0 pages.
Found CPU 0 (node=f0084148,mid=0)
Found 1 CPU prom device tree node(s).
Kernel command line: ro init=/bin/sh
Calibrating delay loop... 878.18 BogoMIPS
Memory: 245040k available (1944k kernel code, 512k data, 168k init)
Dentry-cache hash table entries: 32768 (order: 6, 524288 bytes)
Inode-cache hash table entries: 16384 (order: 5, 262144 bytes)
Mount-cache hash table entries: 4096 (order: 3, 65536 bytes)
Buffer-cache hash table entries: 8192 (order: 3, 65536 bytes)
Page-cache hash table entries: 32768 (order: 5, 262144 bytes)
POSIX conformance testing by UNIFIX
PCI: Probing for controllers.
PCI: Found SABRE, main regs at 000001fe00000000, wsync at 000001fe00001c20
SABRE: Shared PCI config space at 000001fe01000000
SABRE: DVMA at c0000000 [20000000]
PCI0(PBMA): Bus running at 33MHz
PCI0(PBMB): Bus running at 33MHz
ebus0: [auxio] [power] [SUNW,pll] [su] [su] [ecpp] [fdthree] [eeprom]
] [watchdog] [display7seg] [beeper] [flashprom] [flashprom] [i2c -> (adc)
 (gpio)] [i2c] [SUNW,lom]
PCIO serial driver version 1.54
su(serial) at 0x1fff13803f8 (tty 0 irq 10,7dc) is a 16550A
su(serial) at 0x1fff13602f8 (tty 1 irq 10,7d4) is a 16550A
power: Control reg at 000001fff1724000 ... powerd running.
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
Starting kswapd
Journalled Block Device driver loaded
pty: 256 Unix98 ptys configured
rtc_init: no PC rtc found
block: 128 slots per queue, batch=32
RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
Uniform Multi-Platform E-IDE driver Revision: 6.31
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
CMD646: IDE controller on PCI bus 03 dev 70
CMD646: chipset revision 3
CMD646: chipset revision 0x03, MultiWord DMA Force Limited
CMD646: 100% native mode on irq 6,7c0
    ide0: BM-DMA at 0x1fe02001020-0x1fe02001027, BIOS settings: hda:pio,
    ide1: BM-DMA at 0x1fe02001028-0x1fe0200102f, BIOS settings: hdc:pio,
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
ide1 at 0x1fe02001010-0x1fe02001017,0x1fe0200101a on irq 6,7c0
hdc: lost interrupt
hdc: lost interrupt
hdc: ATAPI 24X CD-ROM drive, 128kB Cache
Uniform CD-ROM driver Revision: 3.12
loop: loaded (max 8 devices)
sunhme.c:v1.99 12/Sep/99 David S. Miller (davem@redhat.com)
eth0-3: Quattro HME (PCI/CheerIO) 10/100baseT Ethernet DEC 21153 PCI Bridge
eth0: Quattro HME slot 0 (PCI/CheerIO) 10/100baseT Ethernet
eth1: Quattro HME slot 1 (PCI/CheerIO) 10/100baseT Ethernet
eth2: Quattro HME slot 2 (PCI/CheerIO) 10/100baseT Ethernet
eth3: Quattro HME slot 3 (PCI/CheerIO) 10/100baseT Ethernet
eth4: HAPPY MEAL (PCI/CheerIO) 10/100BaseT Ethernet 08:00:20:c1:fd:2e
eth5: HAPPY MEAL (PCI/CheerIO) 10/100BaseT Ethernet 08:00:20:c1:fd:2e
SCSI subsystem driver Revision: 1.00
sym.1.2.0: setting PCI_COMMAND_PARITY...
sym.1.2.0: setting PCI_COMMAND_INVALIDATE.
sym0: <875> rev 0x3 on pci bus 1 device 2 function 0 irq 4,7e0
sym0: No NVRAM, ID 7, Fast-20, SE, parity checking
sym0: SCSI BUS has been reset.
scsi0 : sym-2.1.17a
  Vendor: SEAGATE   Model: ST39102LCSUN9.0G  Rev: 0828
  Type:   Direct-Access                      ANSI SCSI revision: 02
  Vendor: SEAGATE   Model: ST39102LCSUN9.0G  Rev: 0828
  Type:   Direct-Access                      ANSI SCSI revision: 02
sym0:0:0: tagged command queuing enabled, command queue depth 16.
sym0:1:0: tagged command queuing enabled, command queue depth 16.
Attached scsi disk sda at scsi0, channel 0, id 0, lun 0
Attached scsi disk sdb at scsi0, channel 0, id 1, lun 0
sym0:0: FAST-20 WIDE SCSI 40.0 MB/s ST (50.0 ns, offset 15)
SCSI device sda: 17689267 512-byte hdwr sectors (9057 MB)
Partition check:
 sda: sda1 sda2 sda3 sda4 sda5 sda6 sda7
sym0:1: FAST-20 WIDE SCSI 40.0 MB/s ST (50.0 ns, offset 15)
SCSI device sdb: 17689267 512-byte hdwr sectors (9057 MB)
 sdb: sdb1
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
usb.c: registered new driver keyboard
usbkbd.c: :USB HID Boot Protocol keyboard driver
mice: PS/2 mouse device common for all mice
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP
IP: routing cache hash table of 2048 buckets, 32Kbytes
TCP: Hash tables configured (established 16384 bind 16384)
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
RAMDISK: Compressed image found at block 0
Freeing initrd memory: 1131k freed
EXT2-fs warning: checktime reached, running e2fsck is recommended
VFS: Mounted root (ext2 filesystem).
serial console detected.  Disabling virtual terminals.
init started:  BusyBox v0.60.3-pre (2002.01.22-00:19+0000) multi-call

I really don't have a clue anymore what to do or where to search further.
Any idea



Reply to: