[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Network card problem: carrier lost

In article <[🔎] Pine.LNX.3.96.1040217155015.16337A-100000@lion.protorusz.hu> 
jana@lion.protorusz.hu writes:

>sunhme.c:v1.99 12/Sep/99 David S. Miller (davem@redhat.com)
>eth0: HAPPY MEAL (SBUS) 10/100baseT Ethernet 08:00:20:85:bf:48 
>sunlance.c:v2.00 11/Sep/99 Miguel de Icaza (miguel@nuclecu.unam.mx)
>eth1: LANCE 08:00:20:85:bf:48 
>eth1: using auto-carrier-detection.
>The eth0 is the "normal" card, the eth1 is the on-board card.
>Note that the hardware addresses of cards are same (equals).
>This is impossible.

Sun follows the ethernet standard, where the ethernet address is
assigned to the system, not the card.  This only causes problems if
you connect multiple interfaces to the same segment or switch.  IBM
didn't assign their systems ethernet addresses so the card
manufacturers needed to put an address on each card.

Some later sun cards and systems have a openboot option to enable card
addresses, but I think your system predates this.

>A tried to start the network interfaces with ifconfig (using different IP 
>The eth0 works fine.
>eth0: Link is up using internal transceiver at 100Mb/s, Half Duplex.

Looks like a 100-megabit hub.

>However the eth1 doesn't work. :-(
>When I'd tried to go up it, it said:
>eth1: Carrier Lost, trying AUI
>I tried to use ping command, the answer was:
>eth1: Carrier Lost, trying TPE 

Lance cards are 10 megabit, are you trying to hook it to a 100 megabit
only hub?

Blars Blarson			blarson@blars.org
With Microsoft, failure is not an option.  It is a standard feature.

Reply to: