[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Network card problem: carrier lost

Hi All,

I'm a new member of this list.
I'm good at Debian, but I'm beginner at Sparc architecture.

I have a Sparc and I've installed Debian Woody (from first official CD
image). Here is the beginning of dmesg output:

PROMLIB: Sun IEEE Boot Prom 3.5.0 1997/01/06 17:59
Linux version 2.4.18
Ethernet address: 08:00:20:85:bf:48

The machine has two network card: one on-board and one "normal" eth card.
There are detected by Linux (dmesg info):

sunhme.c:v1.99 12/Sep/99 David S. Miller (davem@redhat.com)
eth0: HAPPY MEAL (SBUS) 10/100baseT Ethernet 08:00:20:85:bf:48 
sunlance.c:v2.00 11/Sep/99 Miguel de Icaza (miguel@nuclecu.unam.mx)
eth1: LANCE 08:00:20:85:bf:48 
eth1: using auto-carrier-detection.

The eth0 is the "normal" card, the eth1 is the on-board card.

Note that the hardware addresses of cards are same (equals).
This is impossible.

A tried to start the network interfaces with ifconfig (using different IP 
The eth0 works fine.
eth0: Link is up using internal transceiver at 100Mb/s, Half Duplex.

However the eth1 doesn't work. :-(
When I'd tried to go up it, it said:

eth1: Carrier Lost, trying AUI

I tried to use ping command, the answer was:

eth1: Carrier Lost, trying TPE 

I don't know why doesn't work the on-board ethernet card.

Please help me!
Maybe special configuration needed for machine or kernel?
Or the on-board card is bad? :-(

The previous OS was Solaris on this machine. It recognised only the eth0
(as hme0), but did not detect the on-board card.
Thanks in advance,

Reply to: