[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installation on SPARCSTATION 20

Hi all,

Thanks for the response. It installed perfectly! I've also rechanged the
partition (thanks for sharing your thoughts).

Now I want to reinstall everything and then start using it :-)
So I've some questions:

1. I've also a tape drive on it. I don't know how I can see if Debian
installed something for it. Anyway, do I've to do something special
during the installation or is it directly supported? Do I've to build
another kernel?

The tape is : Conner CTD8000H/R-S//4326NP/RP

2. I've a black and white screen. How do I run the install in mono? If
read something about the parameter 'mono', but I don't know where I to
pass it or define it.

3. I've installed X-Windows during the install without a problem, but,
it's in color. How can install the sun-mono X-Windows during the
install? Or does it automatically goes to the color version?

Thanks in advance,

Brenda J. Butler wrote:
> On Mon, May 27, 2002 at 12:08:10PM +0200, Tom Deprez wrote:
>> First : I'm new to Debian, I'm new to Sparcs, so I'm really a newbie
>> on both of these!
> Welcome!  Gotta love these 20" screens!
>> (I received the sparc, because otherwise they throw it away and I
>> wanted to try Debian out,
>> since most people tell me it's the best linux os for a server)
> Ah, reduce, reuse, recycle.  Good stuff.
>> I've followed the installation instructions and all went ok, until
>> the end:
>> 1. Creating the rescue floppy didn't work :-( It failed every time I
>> tried 2. When I try to boot with 'boot disk', I get the following
>> message:
>> cannot find /vmlinuz (unknown ext2 error)
>> I'm a little bit stuck here, since nothing is familiar for me. I've
>> looked with google for
>> answers, but most of them were a little bit cryptic, so I'm not
>> wiser at the moment.
> Hah!  I've just worked on that very problem.
> It seems the kernel gets written to /boot/vmlinuz-2.2.19-sun4cdm
> and a link gets created (see below for how) to link
> /boot/vmlinuz to /boot/vmlinuz-2.2.19.  So the link from vmlinuz
> points nowhere.
> I fixed this by editing /etc/silo.conf to say:
> image=1/vmlinuz-2.2.19-sun4cdm
> (it used to say image=1/vmlinuz-2.2.19, or was it just
> image=1/vmlinuz? no matter)
> You should probably edit it to say 2/vmlinuz-2.2.19-sun4cdm -
> substitute your kernel version - I was installing potato stable R 4.
> The 1/ and 2/ are which partition the image is on.  In my case boot
> is on the first partition so I write 1/vmlinuz-2.2.19-sun4cdm
> Your boot is on your second partition so you write 2/vmlinuz-2.2.19-
> sun4cdm. Leave off the /boot part of the path, because that's _not_
> on your second partition.  Your vmlinuz image really is at the top of
> your second partition.
> Note that I put /boot on the first partition because I wanted to make
> absolutely sure that the image would be at the beginning of the disk.
> But your arrangement puts the image close enough to the beginning of
> the disk so you don't need to re-arrange it now that it's done.
>> Then I created the following partitions:
>> sb1 50 MB /
>> sb2 16 MB /boot
>> sb3 the special partition
>> sb4 128 MB swap
>> sb5 100 MB /home
>> sb6 rest of the 2.1 GB /usr
>> sba1 4.1 GB /var
>> sba2 special partition
>> This is mainly a server for the intranet, I hope my partitioning is
>> ok. If not, please give some
>> advice. Highly appreciated!
> No special partition for /tmp, so it will share /, and you have only
> 50MB for / Well I've never run a dedicated server, but I'm wondering
> if you haven't skimped a bit on /tmp space.  Servers may (or may not,
> depending on how you've configured them) use a fair chunk of /tmp
> space.
> Also you can configure some servers to run as their own user, so they
> might need space in /home.  Eg, amanda (a tape backup software) might
> be installed/ configured to run as user amanda.  This is handy to
> keep servers from tromping on each others files, either inadvertently
> or as a way to limit the damage that a cracker can do once they "own"
> a server. Of course you can always set their accounts in /usr... not
> sure what the FSH has to say about this topic.
> Maybe someone more experienced with servers/security can comment.
>> Now, my questions:
>> What did I do wrong?
> I think there's a wee bug in the install program, you didn't do
> anything wrong.  This bug only seems to show up when you have a
> separate boot partition, as you noticed.
>> Why couldn't I create the rescue floppy? Is there a way to still
>> create it? How can I proceed with the installation?
> I don't have a floppy drive in my SS20, sorry can't help you here.
> On Mon, May 27, 2002 at 07:19:26PM +0200, Tom Deprez wrote:
>> Thanks for your response!
>> Can you give me how to create that  symlink ?
> ln -s old new
> ln(1)  (To read the man page for ln, type 'man ln' at the prompt.)

To UNSUBSCRIBE, email to debian-sparc-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: