[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Sparc Potato mouse and keyboard setup

G'day Renato,

You need to link /dev/mouse to /dev/sunmouse

PS. Its a bus mouse not ps2.

Check the back of your keyboard for the type eg. mine is a US type 5, run
kbdconfig as root, choose /sun for the keyboard definition, and choose
sunkeymap for the layout if you have a US keymap.

Otherwise you will need to find out what keymap you've been using with

Don't use gdm.


Peter Firmstone.

On Wed, 14 Mar 2001, Renato Braga de Lima Guedes wrote:

>     Guys,
>     I had used Debian Slink on my Sun Ultra 10 free of problems, but now
> I am trying to install the Debian Potato (2.2 r 2)  and i'm having a lot
> of trouble to configure my mouse and my keyboard to X enviroment.
>     The keyboard works OK out of the X enviroment, but whem the X is
> turned on the keyboard seems to change some characters. For example, the
> character "c" appear when the ENTER key is pressed. I saw, during the
> instalation process, that  a kind of X-Windows filter program is
> instaled and a keyboard options screen appear. In fact, I am not sure
> about wich keyboard select from that list. Since my keyboard is common
> Sun one (QWERTY with nothing special) I have tried the Suns Keyboad
> standart options, with no success.
>     The mouse problem is more challenger because there are few options
> during the instalation process and I already have tryed all of them. Due
> to a instalation bug, a had to make the simbolic link from /dev/mouse to
> /dev/ttyS0 (I tryed to do it to /dev/ttyS1 too) that it's necessary to
> start the X Windows enviroment, and it was OK, no problems. But when the
> X Windows is turned on (the graphical screen appears OK) the mouse
> pointer does not move. I don't know what to do. This damn mouse worked
> OK with Slink for almost two years and this problem is becaming very
> boring. My mouse is a Sun mouse, with 3 butons, and it's connected to
> keyboard trougthout a rounded conector. The keyboard is connected to
> computer trougthout a rounded connector too. I suspect that it is a PS/2
> mouse (due to round conector) but I already have selected this options
> and things didn't became better. I readed in the Debian.org home page
> that there are some bug reports about PS/2 mouses but I couldn't find a
> solution to this problem.
>     I would really apreciate if anyone could help me. Thanks.
>     Best regards,
>     Renato Guedes
> --  
> To UNSUBSCRIBE, email to debian-sparc-request@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: