[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: Pb with Linux et Sparc 2 when booting


The bootrecord on a PC is 512 bytes, while on the Sun it has a bigger size.
That's why the Sun can't read its bootsector.
I think you won't get away with this like that.
Do you have a local network? Then you might consider to install the Sparc
over NFS.
I have attached my story about how I did it.
I also posted this several times to the list, but it seems that nobody
reads it. And then, afterwards, I have to send it out to several people asking
for it...
Anyhow, that's life...

On 27-Feb-99 Alain & Estelle BARBET wrote:
> Hello !
> Thanks for your job !
> I have a problem ....
> I want to install Suse Linux 5.2 on a Sun Sparc2 without CD-ROM drive .
> So I put the SCSI hard drive on a PC, installed linux and reboot . Lilo
> & Linux start . OK, so I put the HD on the Sparc.
> When boot I have the following message :
> Boot device: /sbus/esp@0,800000/sd@3,0 Files and args :
> Bad magic number in disk label
> Cant't open Sun disk label package
> Can't open boot device
> Please, can you help me ?
> -
> To unsubscribe from this list: send the line "unsubscribe sparclinux" in
> the body of the message to majordomo@vger.rutgers.edu

Isn't this my STOP?!

Best regards, don't let the bits byte!
Ivo Naninck

Hello All,

For what it's worth, I describe here my experience from my Linux-Sparc
project. I must say, that thanks to many hints from this list, I got it
working now.
Do what you want with it..., however, it might even help some of you.

Goal was to have RedHat-5.2 (Apollo) Linux-Sparc running on my Sun machine.

Involved hardware:
- Sun Sparc Station 2, Rom revision 2.4, with 32MB, 
  2 harddisks and a floppy-drive, keyboard and mouse.
- Intel Linux machine running SlackWare with kernel 2.0.36.
- Ethernet network, machines connected through a simple hub.

First step:
Tried to boot the Sun over the network from the Intel-box using
the tftpboot mechanism. I couldn't get that to work. I kept getting
those messages "the file just loaded does not appear to be executable".
I discovered (from docs) that Suns' tftpboot request is somewhat different.
I was advised to try the 'tftp' and 'in.tftpd' from RedHat on my Intel-box.
That would overcome the problem...
That also didn't work, I think because RedHat leans on libc.so.6, while
SlackWare (my system) leans on libc.so.5.

Second step:
Finding the images for the boot-floppies. That wasn't too hard, but read on!
I got them from vger.rutgers.edu. I pulled 2 floppies from the shelf and
put the images on it;
dd if=boot.img of=/dev/fd0 and
dd if=ramdisk.img of=/dev/fd0
Great!, power up the Sparc, press 'Stop-A' simultanously while the Sparc
is testing itself and type 'b /fd' while at the '>' prompt, or
'boot /fd' while at the 'boot' prompt, after entering 'n' for 'new command
Unfortunately I got the message 'Can not read Sun label', or something
similar. I discovered that Suns' boot-loader is longer than 512 bytes.
You must create your floppies as follows: 'fdformat' them on a Sun-machine
(well, that's what I did, didn't test a format on an Intel-box), then
on the Intel box I put the images on the floppies again, but slightly
different now:
dd if=boot.img of=/dev/fd0 bs=1k
dd if=ramdisk.img of=/dev/fd0 bs=1k
Notice the 'bs=1k'!!!!
That did the trick, the system boots from the two floppies now.

Third step:
Configuring the Intel-Linux-box as a NFS-server. That wasn't too hard.
Just follow the NFS-HOWTO. You sure know where to find the HOWTO's...
I was lucky I have yet another Linux-box, from which I could see that
NFS is really working. 

Fourth step:
Creating a RedHat installation-tree on the Intel-Linux-box.
This is TRICKY!!!!!!!!
>From all over the world, I downloaded the stuff needed;
- boot-floppies from vger.rutgers
- installation images from ftp.funet.fi
- RPMS from many mirrors, due to time-outs and that kind of misery...

So, I ended up with the following directory structure (where /usr1 can also
be /mary or /nfs or whatever, but keep the redhat/RedHat !!!).

/usr1/redhat/RedHat  ('/usr1/redhat' is what you must NFS-export)
in 'RedHat' there must be two directories, the first is
'base', which must contain
/usr1/redhat/RedHat/base> ls -l
total 3829
-rwxrwxrwx   1 kde      users       12944 Jan 30 20:50 comps
-rwxrwxrwx   1 kde      users     3864673 Jan 30 20:50 hdlist
-rwxrwxrwx   1 kde      users       22622 Jan 30 20:50 install3.tr

and a directory 
'RPMS', which must contain the 'xyz.rpm' files which contain the packages
you can install later on.

In 'RedHat' there is also a file with zero-length called 'sparc'
I have attached my directory structure, so you can see it more clearly...

Fifth step:
Okay!, let's install!!!
Fire up the Sparc, boot the floppies, and see the installation-tool starting.
Just answer the questions (you need to select the NFS-install-method), partition
your disks and so on and then you get a question where you need to give
the name (or IP-address) of you NFS-server as well as the redhat-installation
directory. You should enter '/usr1/redhat' here.
And then comes the tricky stuff.
I kept getting messages that there "doesn't seem to be a RedHat installation-
tree in the directory specified"... :-((( 
Whatever I tried, I just wouldn't listen to me.

Then, from this list, I got the advise to download BOTH the boot-images
AND the images that go into 'base' from the SAME ftp-site.
Why? I don't know, they are all ftp-mirrors, aren't they?
Well, being at a dead point, that was the one thing to try.
I downloaded the stuff from ftp.redhat.com, created new floppies and put
the '/usr1/redhat/RedHat/base'-stuff in place.
Guess what, it works!!!
Take care, this is only needed for the images, to my experience...
I downloaded the RPMS from all over the universe and they all work...

At some point the installation tool presents you a list of packeages
to install. That are the RPMS I mentioned before. Just select what you need
and press OK.
Enjoy some coffeine and some nicotine eventually and you'll be asked to
reboot the system, WOW, DONE!!!!

Sixth step:
Well, not quite yet....
The box didn't boot, "Illegal Instruction" :-((((((((
I suspected this to be a problem with the way the sun describes it's hardware
in the boot-prom (setenv boot-device ....), but I didn't know what to answer.
At the end of the installation you get a question about entering some
SILO-parameters, I tried 'root=/dev/sda1', which didn't work.

Then, again from this list, I was advised to change the 'boot-device' in the
prom to 'boot-device diskx:y', where x = the SCSI-id of the bootdisk and
y = the partition to boot.
In my case (/dev/sda1) this worked out to be 'disk1:1', so:
'setenv boot-device disk1:1'
Type 'boot' now at the 'OK' prompt and you'll be fine.
Oh, one last test, does it still work after a power-cycle on the Sun?
Wait a moment.................................................
Yes, it does..... :-))))))))

Really bizar; a Sun which runs Linux and gives you a Win95 GUI by default...

Good Luck!


Reply to: