[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: (mostly) successful floppy install on sparc2

Jeffrey Ebert wrote:
> I wanted to say thank you to the debian-sparc developers. You have done a
> nice job getting this distribution ready to release.
> First off, Eric Delaunay did a great job with the boot floppies. Everything
> went quite well. In the past, I always had to type "boot fd;1/linux" or
> something, but I tried "boot floppy" this time, and it worked perfectly.

Not all is my job.  I guess it is the new silo 0.8.5 which is working right
now.  At least for you ;-(  Steve reported some troubles with it on new sparc
workstations (SS10 & SS20).  Unfortunately I don't have one handy to do more
testing.  Sorry Steve ;-((

> The installation went well, except for some weird error messages that
> didn't seem to effect anything. I think they have been mentioned here
> before, but from memory, here are a couple:
> 1) "Cannot open /dev/tty0." This was towards the beginning of the install,
> either right before or right after keyboard selection. I have no keyboard
> or monitor, so I do everything through the serial port, /dev/ttyS0.

I know.  I didn't removed the keyboard settings yet when the terminal is a
serial console.  I don't know whether the installation works straightforward
if there is no keyboard configured at all (I tried to be conservative).
I will work on it for a next release (for potato).
Anyways it doesn't hurt much.

> 2) "Cannot find module nfs." This was when I tried to mount a nfs partition
> from my other machine to install the base system tar.gz file. It worked
> anyway. It must think that the nfs.o module needs to be modprobe'd, but
> this kernel has nfs support compiled in.

Yes, dboostrap have to check for nfs already present in kernel before trying
to load the nfs module.  Another point to fix...  for potato, I'm afraid.

> I like the part that lets the user choose from a variety of tasks and
> profiles for their machine. If the dependencies were OK, then this would be
> great. Unfortunately, I was just trying to install the server stuff, and I
> got a whole bunch of other things, probably due to the xbase dependency
> mess that hasn't settled out yet. For new users, this is going to be really
> good. Send my compliments to whomever is working on this feature.

Stéphane Bortzmeyer is the person who wrote it.  Many thanks to him.

> The serious problem I had was that apt update, when run from dselect, was
> horribly broken until I did a few hand upgrades. It segfaulted when calling
> dpkg -merge, I think. I eventually got it fixed, but I am not exactly sure
> when it started working (sorry about not taking better notes).
> 1) I upgraded libc6, and libstdc++, but neither of those seemed to help.
> 2) I upgraded apt, even though it was the same version. Still no good.
> 3) I upgraded dpkg, even though it was the same version. Now it works
> great!
> This isn't terribly logical, so maybe my testing after step 1 or step 2 was
> inadequate.

I also experienced this problem but did'nt investigate so far.  I switched to
another method instead ;-((
Maybe apt doesn't like inconsitencies in the dpkg database ?  Actually all
dependencies are'nt met because of missing packages in tasks & profiles.

Thanks for your report, Jeffrey.
BTW, I uploaded a new set of bootdisks few hours ago.
They are in their way to master and are also available at my ftp site (look at
ftp://lix.polytechnique.fr/pub/Linux/debian/sparc/exp/disks-sparc/current ).

 Eric Delaunay                 | "La guerre justifie l'existence des militaires.
 delaunay@lix.polytechnique.fr | En les supprimant." Henri Jeanson (1900-1970)

Reply to: