[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

(mostly) successful floppy install on sparc2

I wanted to say thank you to the debian-sparc developers. You have done a
nice job getting this distribution ready to release.

First off, Eric Delaunay did a great job with the boot floppies. Everything
went quite well. In the past, I always had to type "boot fd;1/linux" or
something, but I tried "boot floppy" this time, and it worked perfectly.

The installation went well, except for some weird error messages that
didn't seem to effect anything. I think they have been mentioned here
before, but from memory, here are a couple:

1) "Cannot open /dev/tty0." This was towards the beginning of the install,
either right before or right after keyboard selection. I have no keyboard
or monitor, so I do everything through the serial port, /dev/ttyS0.

2) "Cannot find module nfs." This was when I tried to mount a nfs partition
from my other machine to install the base system tar.gz file. It worked
anyway. It must think that the nfs.o module needs to be modprobe'd, but
this kernel has nfs support compiled in.

I like the part that lets the user choose from a variety of tasks and
profiles for their machine. If the dependencies were OK, then this would be
great. Unfortunately, I was just trying to install the server stuff, and I
got a whole bunch of other things, probably due to the xbase dependency
mess that hasn't settled out yet. For new users, this is going to be really
good. Send my compliments to whomever is working on this feature.

The serious problem I had was that apt update, when run from dselect, was
horribly broken until I did a few hand upgrades. It segfaulted when calling
dpkg -merge, I think. I eventually got it fixed, but I am not exactly sure
when it started working (sorry about not taking better notes).

1) I upgraded libc6, and libstdc++, but neither of those seemed to help.

2) I upgraded apt, even though it was the same version. Still no good.

3) I upgraded dpkg, even though it was the same version. Now it works

This isn't terribly logical, so maybe my testing after step 1 or step 2 was

Outstanding problems with package dependencies:

1) xlib6g depends on xbase (>= I am trying to have a few X
clients with no X server.

2) apache depends on apache-common (>= 1.3.4). The version of both apache
and apache common is 1.3.3-6, so that makes little sense to me.

I realize that these are probably bugs against the packages, and I'll check
the bug tracking system shortly.

Thanks again,

Jeff Ebert

Reply to: