[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Floppy Installation on Sparcstation 1

Alex Yung wrote:
> I believe I understand why now.  The "install.txt" suggested to use
>     dd if=file of=/dev/fd0 bs=512 conv=sync ; sync
> If I don't fill the file with zeroes, the last block does not get written
> to disk.

The root.bin I downloaded is 1054057 bytes. That works out to 2058.705
blocks of 512 bytes each. Using dd to write the file to /dev/fd0

dd if=root.bin of=/dev/fd0 bs=512 conv=sync;sync
2058+1 records in
2059+0 records out

So I think dd does fill in something to make up for the 0.295 blocks
that is missing. In any case, even after filling up root.bin with the
151 bytes (using /dev/zero), the kernel still panics with the same
magic number (0xf1f9e4ad).

I tried one other thing. I gunzipped root.bin. This gave me the
unzipped version that is 2867200 bytes. I then tried to write this to
floppy using dd. After writing 2880 records, it ran out of space, as
expected. Anyway, I then inserted this floppy when prompted for the
root floppy. Now, the kernel did not panic, but gave a message about
mounting the root fs. Of course, then it gave a series of error
messages about not being able to access blocks since the limit on the
floppy was 2880 only. So, there seems to be some problem with
unzipping the root.bin.

Thanks to both of you for your help. I will probably try a NFS install


Reply to: