[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Floppy Installation on Sparcstation 1

Alex Yung wrote:
> On Thu, 28 Jan 1999, Ashok Gopalakrishnan wrote:
> > 
> > Upon inserting the root floppy and pressing enter:
> > 
> > vfs_read_super: bad magic number 0xf1f9e4ad on dev 2/0
> > kernel panic: VFS: Unable to mount root fs on 2:00
> > Press L1-A to return to the boot prom
> I ran into this problem a week ago.  It appears that the file "root.bin"
> is 151 bytes short.  This is how I fix it.  I just appended 151 bytes
> of zeroes to this file then recreated the floppy with dd.  It worked
> after this.  You might want to give it a try.

Strange behavior :-(
Why a bunch of zeros added at the end of the file are making the disk to work?
Even if the sparc is reading more bytes than the exact size of root.bin, I
thought the extra part was not used at all.
It could be linux kernel related problem because the loading of the ramdisk is
done by the kernel itself.

Any pointers?

 Eric Delaunay                 | "La guerre justifie l'existence des militaires.
 delaunay@lix.polytechnique.fr | En les supprimant." Henri Jeanson (1900-1970)

Reply to: