[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Floppy Installation on Sparcstation 1

On Thu, 28 Jan 1999, Ashok Gopalakrishnan wrote:
> I am trying to install debian on a sparcstation 1 with 16MB of RAM.
> >From ftp.debian.org, in the directory
> pub/debian/dists/unstable/main/disks-sparc/1998-12-07, I downloaded
> the files base14-1.bin thru base14-2.bin, resc1440.bin, drv1440.bin
> and root.bin. Using rawrite2, I copied these to floppies.
> I then booted the sparc with the 'boot floppy' command and at the SILO
> boot prompt, entered '/fd;/linux' to start the process. After
> uncompressing the kernel image and detecting the hardware on the
> machine, I am prompted to insert the root floppy and press enter. When
> I do this however, the kernel panics, saying that it cannot mount the
> root files system. Here are the exact messages:
> ......
> Partition check:
>    sda: sda1 sda2 sda3 sda4 sda5 sda6 sda7 sda8
>    sdb: sdb1 sdb2 sdb3 sdb4 sdb5 sdb6 sdb7 sdb8
> floppy 0: Warning disk change called early
> VFS: Insert root floppy and press enter
> Upon inserting the root floppy and pressing enter:
> vfs_read_super: bad magic number 0xf1f9e4ad on dev 2/0
> kernel panic: VFS: Unable to mount root fs on 2:00
> Press L1-A to return to the boot prom

I ran into this problem a week ago.  It appears that the file "root.bin"
is 151 bytes short.  This is how I fix it.  I just appended 151 bytes
of zeroes to this file then recreated the floppy with dd.  It worked
after this.  You might want to give it a try.

Reply to: