[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Blocking uploads of packages involved in the Python 2.5 transition



On 25/04/2008, Adeodato Simó wrote:
> By looking at the dependencies, blender is not part of this
> transition, because putting python-defaults 2.5 in testing does not
> render it uninstallable. So feel free to upload.

Thanks; thought so, but wanted to make sure.

> As an aside matter, I have no idea, whether being compiled for
> python2.4 but allowing co-installability with another default python
> version is the correct thing to do or not.

If your concern is about how the shipped scripts are executed, they all
begin with a “#!BPY” shebang, and Blender runs them with the interpreter
it was compiled against. That explains why the submitter of #477761 got
a syntax error: his python2.5 — fancy “foo if bar else baz” — script was
executed by python2.4, against which Blender was compiled until now;
although his python version is 2.5.2-1.

Mraw,
KiBi.

Attachment: pgpNg9vlIQcLn.pgp
Description: PGP signature


Reply to: