[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Planning for an upgrade path from etch to lenny for mailman

On Wed, Jan 24, 2007 at 01:02:04PM +0100, Thijs Kinkhorst wrote:
> On Tue, 2007-01-23 at 11:50 +0100, Martin Schulze wrote:

>> Please keep in mind that the upgrade path from etch to lenny needs
>> to work for etch r0 to lenny r0 as well.

> So I've understood, (...)

Anyway, vorlon has unblocked the testing transition of my upload
adding the said bin/export (1:2.1.9-5), and it should go in as soon as
alpha autobuilds/uploads it, so hopefully etch r0 to lenny r0 upgrades
will work.

New idea: if we really need an updated bin/export script for the etch
-> lenny upgrade, we can package it separately (in a different
package, e.g. mailman-2.1-export) have mailman 2.1->2.2 upgrades bail
out if that package is not installed (unless admin debconf-agrees to
data loss). Hmm... Would have to analyse what the dependencies of this
package should be...

 - Cannot depend: Mailman (<< 2.2), because then apt/dpkg would remove
   it before upgrading mailman.

 - But that script cannot work in the absence of mailman 2.1...

>> Then the best would be to provide mailman2.1 in lenny and allow an
>> upgrade from mailman2.1 to mailman2.2 *in* lenny.

> That's certainly possible, but would require (more than) doubling of
> the security support for mailman. We're quite motivated to prevent
> that where possible.

In particular, it would most probably require security-supporting a
version that upstream does not support anymore, a situation I'm very
eager to avoid.


Reply to: