[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

ABI breakage in libmysqlclient15off_5.0.24-1 - binNMU possible?


MySQL introduced a ABI incompatibility in libmysqlclient15off_5.0.24-1 which
already caused a lot of segfaults and crashes esp. with the Perl bindings.
A patch is available at least.

Is it possible to schedule a binNMU rebuild for all packages depending on
libmysqlclient15off without a package name change and just change
the line "dh_makeshlibs -V"?
I guess not as it was necessary back in 2006-03-15 at the last ABI



P.S.: I should start with calling it libmysqlclient15abi3 and so on :)

Reply to: