[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ABI breakage in libmysqlclient15off_5.0.24-1 - binNMU possible?

On Fri, Aug 25, 2006 at 10:25:25PM +0200, Christian Hammers wrote:

> MySQL introduced a ABI incompatibility in libmysqlclient15off_5.0.24-1 which
> already caused a lot of segfaults and crashes esp. with the Perl bindings.
> A patch is available at least.

> Is it possible to schedule a binNMU rebuild for all packages depending on
> libmysqlclient15off without a package name change and just change
> the line "dh_makeshlibs -V"?
> I guess not as it was necessary back in 2006-03-15 at the last ABI
> breakage?

What do you mean, 'change the line "dh_makeshlibs -V"'? A binNMU can't
include any changes to the source, but this line shouldn't appear in the
packages that *depend* on libmysqlclient15off anyway (or at least it's not
relevant to this change).

Please fix the library first -- ideally with a package name change or by
restoring the ABI, but at least with a bumped shlibs -- and then we can
binNMU the packages depending on it as needed.

Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.
vorlon@debian.org                                   http://www.debian.org/

Reply to: