[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#231339: marked as done ([kregexpeditor] Old package libkregexpeditor not removed on upgrade)



Your message dated Mon, 09 Feb 2004 18:12:57 +0100
with message-id <87ad3sw50m.fsf@student.kuleuven.ac.be>
and subject line Bug#231339: [kregexpeditor] Old package libkregexpeditor not removed on upgrade
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--------------------------------------
Received: (at submit) by bugs.debian.org; 5 Feb 2004 22:42:46 +0000
>From aragorn@tiscali.nl Thu Feb 05 14:42:46 2004
Return-path: <aragorn@tiscali.nl>
Received: from (elrond.fjphome.nl) [195.240.184.66] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1AosCs-0007CG-00; Thu, 05 Feb 2004 14:42:46 -0800
Received: from galadriel.fjphome.nl ([10.19.66.21] ident=fjp)
	by elrond.fjphome.nl with esmtp (Exim 3.35 #1 (Debian))
	id 1AosCM-0000Qf-00
	for <submit@bugs.debian.org>; Thu, 05 Feb 2004 23:42:14 +0100
From: Frans Pop <aragorn@tiscali.nl>
To: submit@bugs.debian.org
Subject: [kregexpeditor] Old package libkregexpeditor not removed on upgrade
Date: Thu, 5 Feb 2004 23:42:13 +0100
User-Agent: KMail/1.6
MIME-Version: 1.0
Content-Disposition: inline
Content-Type: text/plain;
  charset="us-ascii"
Content-Transfer-Encoding: 7bit
Message-Id: <200402052342.13859.aragorn@tiscali.nl>
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_02_01 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-5.0 required=4.0 tests=HAS_PACKAGE autolearn=no 
	version=2.60-bugs.debian.org_2004_02_01
X-Spam-Level: 

Package: kregexpeditor
Version: 4:3.2.0-0woody1
Severity: serious

The package kregexpeditor in the backports for Woody on download.kde.org has:
   Version: 4:3.2.0-0woody1
-> Replaces: libkregexpeditor
   Provides: libkregexpeditor
   Depends: kdelibs4 (>= 4:3.2.0), ...
-> Conflicts: libkregexpeditor

However, when I updated from the 3.1.4 backports, the old package 
libkregexpeditor_4:3.1.4-0woody1 was not removed and is now shown as obsolete 
in dselect.

Maybe Replaces and Conflicts should be 'libkregexpeditor (<4:3.2)'?

I successfully manually deleted the old package with 'dpkg -r 
libkregexpeditor'.

---------------------------------------
Received: (at 231339-done) by bugs.debian.org; 9 Feb 2004 17:12:05 +0000
>From dominique.devriese@student.kuleuven.ac.be Mon Feb 09 09:12:05 2004
Return-path: <dominique.devriese@student.kuleuven.ac.be>
Received: from thumbler.kulnet.kuleuven.ac.be [134.58.240.45] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1AqEx3-000451-00; Mon, 09 Feb 2004 09:12:05 -0800
Received: from localhost (localhost [127.0.0.1])
	by thumbler.kulnet.kuleuven.ac.be (Postfix) with ESMTP
	id 5E9FA137CEA; Mon,  9 Feb 2004 18:11:33 +0100 (CET)
Received: from antonius.kulnet.kuleuven.ac.be (antonius.kulnet.kuleuven.ac.be [134.58.240.73])
	by thumbler.kulnet.kuleuven.ac.be (Postfix) with ESMTP
	id DB473137B66; Mon,  9 Feb 2004 18:11:32 +0100 (CET)
Received: from appel (domi.kotnet.org [10.0.57.168])
	by antonius.kulnet.kuleuven.ac.be (Postfix) with ESMTP
	id C6F7E4C0D1; Mon,  9 Feb 2004 18:11:32 +0100 (CET)
Received: from domi by appel with local (Exim 3.36 #1 (Debian))
	id 1AqExt-0007yS-00; Mon, 09 Feb 2004 18:12:57 +0100
To: Frans Pop <aragorn@tiscali.nl>
Cc: 231339-done@bugs.debian.org
Subject: Re: Bug#231339: [kregexpeditor] Old package libkregexpeditor not
 removed on upgrade
References: <200402052342.13859.aragorn@tiscali.nl>
	<200402082215.37049.aragorn@tiscali.nl>
	<871xp5i7ju.fsf@student.kuleuven.ac.be>
	<200402082253.23663.aragorn@tiscali.nl>
From: Dominique Devriese <dominique.devriese@student.kuleuven.ac.be>
Date: Mon, 09 Feb 2004 18:12:57 +0100
In-Reply-To: <200402082253.23663.aragorn@tiscali.nl> (Frans Pop's message of
 "Sun, 8 Feb 2004 22:53:23 +0100")
Message-ID: <87ad3sw50m.fsf@student.kuleuven.ac.be>
User-Agent: Gnus/5.1002 (Gnus v5.10.2) XEmacs/21.4 (Reasonable Discussion,
 linux)
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Sender: Dominique Devriese <dominique.devriese@student.kuleuven.ac.be>
X-Virus-Scanned: by KULeuven Antivirus Cluster
Delivered-To: 231339-done@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_02_01 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-3.0 required=4.0 tests=HAS_BUG_NUMBER autolearn=no 
	version=2.60-bugs.debian.org_2004_02_01
X-Spam-Level: 


Frans Pop writes:

> On Sunday 08 February 2004 22:29, Dominique Devriese wrote:
>> I thought the problem was about a package remaining installed while
>> it should not have been, which is hardly going to cause an upgrade
>> to abort.

> Sorry, got confused. This is what caused the abort.
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=231406

> After solving that and finishing the upgrade with apt-get
> dist-upgrade. I noticed that libkregexpeditor_4:3.1.4-0woody1 was
> shown as obsolete.

Ok, I understand now.  This is not a problem in the kregexpeditor
package, I think.  You should simply remove the obsolete package with
your favourite package installation tool.  You can use aptitude,
deborphan, or debfoster to find obsolete or unnecessary libraries.

thanks
domi



Reply to: