[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#128444: zope-zpatterns_0.4.3p2-0.2(unstable/sparc): build-depends on a package with interactive install

Package: zope-zpatterns
Version: 0.4.3p2-0.2
Severity: serious
Justification: alpha being out of date will keep it out of testing

Please don't build-depend on zope, it's postinst is interactive which
means it can't be installed by build daemons.  Gregor suggested a
better solution in #86722 (namely that the needed header files be
copied to zope-zpatterns source), please use that instead.

| Automatic build of zope-zpatterns_0.4.3p2-0.2 on vore by sbuild/sparc 1.159
| Build started at 20020108-1240
| ******************************************************************************


| ** Using build dependencies supplied by package:
| Build-Depends: debhelper, python2.1, zope


| Setting up zope (2.4.99beta3-0.2) ...
| WARNING: The default http port of ZServer has been changed to 9673,
|   since 8080 conflicted with proxy server.
|   If you're used to access Zope as http://localhost:8080/, you'll
|   now have to use http://localhost:9673/.
|   For further information about configuring ZServer, please refer
|   to /usr/share/doc/zope/README.Debian.
| Press Enter to continue: dpkg: error processing zope (--configure):
|  subprocess post-installation script returned error exit status 1
| Errors were encountered while processing:
|  zope
| E: Sub-process /usr/bin/dpkg returned an error code (1)
| apt-get failed.
| Package installation failed

A complete build log can be found at


Reply to: