[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#128444: marked as done (zope-zpatterns_0.4.3p2-0.2(unstable/sparc): build-depends on a package with interactive install)



Your message dated Wed, 16 Jan 2002 15:08:44 -0500
with message-id <E16QwMW-0003Ze-00@auric.debian.org>
and subject line Bug#128444: fixed in zope-zpatterns 0.4.3p2-0.3
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--------------------------------------
Received: (at submit) by bugs.debian.org; 9 Jan 2002 16:58:24 +0000
>From james@ruari-quinn.demon.co.uk Wed Jan 09 10:58:24 2002
Return-path: <james@ruari-quinn.demon.co.uk>
Received: from cicero.e-mis.co.uk [212.240.194.162] (mail)
	by master.debian.org with esmtp (Exim 3.12 1 (Debian))
	id 16OM3U-0001vg-00; Wed, 09 Jan 2002 10:58:24 -0600
Received: from tacitus.systems
	([172.21.77.253] helo=tacitus ident=mail)
	by cicero.e-mis.co.uk with esmtp (Exim 3.32 #1 (Debian))
	id 16OM3L-0005Rn-00
	for <submit@bugs.debian.org>; Wed, 09 Jan 2002 16:58:15 +0000
Received: from james by tacitus with local (Exim 3.33 #1 (Debian))
	id 16OM3K-0003pQ-00
	for <submit@bugs.debian.org>; Wed, 09 Jan 2002 16:58:14 +0000
To: submit@bugs.debian.org
Subject: zope-zpatterns_0.4.3p2-0.2(unstable/sparc): build-depends on a package with interactive install
Mail-Copies-To: never
From: James Troup <james@nocrew.org>
Date: 09 Jan 2002 16:58:14 +0000
Message-ID: <87vgeblavt.fsf@tacitus.systems>
Lines: 44
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Sender: James Troup <james@ruari-quinn.demon.co.uk>
Delivered-To: submit@bugs.debian.org

Package: zope-zpatterns
Version: 0.4.3p2-0.2
Severity: serious
Justification: alpha being out of date will keep it out of testing

Please don't build-depend on zope, it's postinst is interactive which
means it can't be installed by build daemons.  Gregor suggested a
better solution in #86722 (namely that the needed header files be
copied to zope-zpatterns source), please use that instead.

| Automatic build of zope-zpatterns_0.4.3p2-0.2 on vore by sbuild/sparc 1.159
| Build started at 20020108-1240
| ******************************************************************************

[...]

| ** Using build dependencies supplied by package:
| Build-Depends: debhelper, python2.1, zope

[...]

| Setting up zope (2.4.99beta3-0.2) ...
| 
| WARNING: The default http port of ZServer has been changed to 9673,
|   since 8080 conflicted with proxy server.
|   If you're used to access Zope as http://localhost:8080/, you'll
|   now have to use http://localhost:9673/.
| 
|   For further information about configuring ZServer, please refer
|   to /usr/share/doc/zope/README.Debian.
| 
| Press Enter to continue: dpkg: error processing zope (--configure):
|  subprocess post-installation script returned error exit status 1
| Errors were encountered while processing:
|  zope
| E: Sub-process /usr/bin/dpkg returned an error code (1)
| apt-get failed.
| Package installation failed

A complete build log can be found at
http://buildd.debian.org/build.php?arch=sparc&pkg=zope-zpatterns&ver=0.4.3p2-0.2

-- 
James

---------------------------------------
Received: (at 128444-close) by bugs.debian.org; 16 Jan 2002 20:11:55 +0000
>From troup@auric.debian.org Wed Jan 16 14:11:55 2002
Return-path: <troup@auric.debian.org>
Received: from auric.debian.org [206.246.226.45] (mail)
	by master.debian.org with esmtp (Exim 3.12 1 (Debian))
	id 16QwPb-0006EZ-00; Wed, 16 Jan 2002 14:11:55 -0600
Received: from troup by auric.debian.org with local (Exim 3.12 1 (Debian))
	id 16QwMW-0003Ze-00; Wed, 16 Jan 2002 15:08:44 -0500
From: Colin Watson <cjwatson@debian.org>
To: 128444-close@bugs.debian.org
X-Katie: $Revision: 1.66 $
Subject: Bug#128444: fixed in zope-zpatterns 0.4.3p2-0.3
Message-Id: <E16QwMW-0003Ze-00@auric.debian.org>
Sender: James Troup <troup@auric.debian.org>
Date: Wed, 16 Jan 2002 15:08:44 -0500
Delivered-To: 128444-close@bugs.debian.org

We believe that the bug you reported is fixed in the latest version of
zope-zpatterns, which has been installed in the Debian FTP archive:

zope-zpatterns_0.4.3p2-0.3.diff.gz
  to pool/main/z/zope-zpatterns/zope-zpatterns_0.4.3p2-0.3.diff.gz
zope-zpatterns_0.4.3p2-0.3.dsc
  to pool/main/z/zope-zpatterns/zope-zpatterns_0.4.3p2-0.3.dsc
zope-zpatterns_0.4.3p2-0.3_i386.deb
  to pool/main/z/zope-zpatterns/zope-zpatterns_0.4.3p2-0.3_i386.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 128444@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Colin Watson <cjwatson@debian.org> (supplier of updated zope-zpatterns package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Tue, 15 Jan 2002 22:48:44 +0000
Source: zope-zpatterns
Binary: zope-zpatterns
Architecture: source i386
Version: 0.4.3p2-0.3
Distribution: unstable
Urgency: low
Maintainer: Debian QA Group <packages@qa.debian.org>
Changed-By: Colin Watson <cjwatson@debian.org>
Description: 
 zope-zpatterns - Database Independence and Framework Integration for Zope
Closes: 128444
Changes: 
 zope-zpatterns (0.4.3p2-0.3) unstable; urgency=low
 .
   * Removed build-dependency on zope, and on the advice of the zope
     maintainer include two header files from zope in this package's source
     instead (closes: #128444).
   * Build-depend on python2.1-dev rather than python2.1, as we use python's
     build scripts.
Files: 
 7cd38c66c275db2989df881d6e1b56dd 653 web extra zope-zpatterns_0.4.3p2-0.3.dsc
 b116fbc6240c8f6af31b4b7fe7179ec3 10761 web extra zope-zpatterns_0.4.3p2-0.3.diff.gz
 718679a36829bb95eef526701ad45435 77756 web extra zope-zpatterns_0.4.3p2-0.3_i386.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see http://www.gnupg.org

iD8DBQE8RLYU9t0zAhD6TNERAla6AJ4nUz/FNaPHz+VPYj7K6NiyRO9V+gCdGXyb
7cLJNYffVwgmiNywARD6eLw=
=igs5
-----END PGP SIGNATURE-----



Reply to: