[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

dh_python and python deps


I'm the straw maintainer, and use dh_python in my debian/rules to do the
compilation and dependency magic.

However, it appears that python2.3-gtk2 is broken and python2.3-bsddb3
is not present yet, so I have decided to make the package explicitly use

I have changed /usr/bin/straw to call python2.2, I depend on python2.2
version of the modules, and build-depend on python2.2, but I get this in
my generated Depends:

Depends: python2.2, python (>= 2.3), python (<< 2.4), ...

Not quite what I was after.  Anyone know what is wrong?

Thanks for any help,
Ross Burton                                 mail: ross@burtonini.com
                                      jabber: ross@jabber.debian.net
                                     www: http://www.burtonini.com./
 PGP Fingerprint: 1A21 F5B0 D8D0 CFE3 81D4 E25A 2D09 E447 D0B4 33DF

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: