[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dh_python and python deps

Le mer 13/08/2003 à 12:38, Ross Burton a écrit :

> I'm the straw maintainer, and use dh_python in my debian/rules to do the
> compilation and dependency magic.
> However, it appears that python2.3-gtk2 is broken and python2.3-bsddb3
> is not present yet, so I have decided to make the package explicitly use
> python2.2.
> I have changed /usr/bin/straw to call python2.2, I depend on python2.2
> version of the modules, and build-depend on python2.2, but I get this in
> my generated Depends:
> Depends: python2.2, python (>= 2.3), python (<< 2.4), ...
> Not quite what I was after.  Anyone know what is wrong?

The .py's in /usr/lib/straw are detected as python modules to be
bytecompiled for the default python version, i.e. 2.3. Maybe you should
put them in /usr/lib/python2.2/site-packages.

I can also add a -V option handling to dh_python, so that you can choose
which python version you want the modules to be compiled with. Do you
think it would be useful ?

 .''`.           Josselin Mouette        /\./\
: :' :           josselin.mouette@ens-lyon.org
`. `'                        joss@debian.org
  `-  Debian GNU/Linux -- The power of freedom

Attachment: signature.asc
Description: Ceci est une partie de message =?ISO-8859-1?Q?num=E9riquement?= =?ISO-8859-1?Q?_sign=E9e?=

Reply to: