Re: python 2.2 -> python 2.3 transition
On Wed, 2003-08-13 at 09:39, John Goerzen wrote:
> On Tue, Aug 12, 2003 at 01:32:33PM -0400, Samuel Bronson wrote:
> > Well, I haven't had any python-related collisions from the pythonX.Y
> > scheme... python (>= 2.2), python (< 2.3) I've seen, of course... it
> > would be so much nicer if someone added debian support to distutils,
> > though ;-) (*hint*)
> Actually, all that have that are now uninstallable. Some important ones
> have that, such as libwxgtk2.4-python.
> Shouldn't they depend on python2.2 instead
No. There is a reason they are not installable... they don't work with
The python-foo packages are there to ensure you can do;
>>> import foo
The pythonX.Y-foo packages are there to ensure you can do;
>>> import foo
The reason most of the python-foo packages have "Depends: python
(>=2.2), python (<<2.3)" is because they only support the first case for
python (2.2). They don't work for python (2.3), which is now in
unstable. They need to be "fixed" before they will work with python
(2.3), which is why they are currently not installable.
Fortunately, most "python-foo" packages are simple wrappers that have
"Depends: python2.2-foo", so they are very small and easy to "fix" for
python (2.3) (changed to "Depends: python2.3-foo").
In the case of libwxgtk2.4-python, there is no libwxgtk2.4-pythonX.Y
packages. There is only one package that supports python (2.2), and this
will need to be fixed now that we have python (2.3). If the package
maintainer so chooses, he could produce a libwxgtk2.4-python2.2 package
for supporting python2.2, but that is up to him/her.
During the transition from python (2.2) to python (2.3) most
"python-foo" packages in unstable will be broken until they are "fixed".
If you wish to install these packages install python (2.2) from testing.
Testing will not transition to python (2.3) until all the python-foo
packages are fixed.
Donovan Baarda <email@example.com>