[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#710297: cups: server-error-internal-error encountered when setting up new printer (Dell 5130cdn color laser)

Package: cups
Version: 1.5.3-5
Severity: normal

Dear Maintainer,

In Debian 7 stable with the provided cups (1.5.3-5) I tried to add a new
printer with external PPD file. The printer is: Dell C3760DN color laser
printer, and I used the PPD given by Dell.
The driver (PPD actually) was obtained from


I converted the RPM to DEB with alien. Installed it, and tried to set up the
printer using the GTK GUI (system-config-printer command). I then specified the
PPD location manually in the dialog titled "Choose Driver". But when I clicked
"Apply" in the "Describe Printer", an error message shows up with this error:

   CUPS server error
   There was an error during the CUPS operation: 'server-error-internal-error'.

I increased the log level to 'debug2' in /etc/cups/cupsd.conf and I found this
portion surrounding the error message in /var/log/cups/error_log:

d [29/May/2013:11:59:33 -0400] cupsdAddPrinter("dellcolor")
d [29/May/2013:11:59:33 -0400] cupsdAddPrinter: Adding dellcolor to Printers
I [29/May/2013:11:59:33 -0400] Setting dellcolor device-uri to
"socket://prism.physics.wm.edu:9100" (was "file:///dev/null".)
d [29/May/2013:11:59:33 -0400] set_printer_defaults: printer-info
d [29/May/2013:11:59:33 -0400] set_printer_defaults: printer-location
d [29/May/2013:11:59:33 -0400] set_printer_defaults: device-uri
d [29/May/2013:11:59:33 -0400] copy_file("/var/spool/cups/00000001",
D [29/May/2013:11:59:33 -0400] CUPS-Add-Modify-Printer server-error-internal-
error: Unable to copy interface script - No such file or directory
E [29/May/2013:11:59:33 -0400] Returning IPP server-error-internal-error for
CUPS-Add-Modify-Printer (ipp://localhost/printers/dellcolor) from localhost
d [29/May/2013:11:59:33 -0400] cupsdProcessIPPRequest: ippLength(response)=153

I checked that in my installation (which is debian 7 amd64, xfce desktop,
installed from LiveCD), there is no subdir /etc/cups/interfaces . I made that
subdirectory manually, and the printer setup process continues. But in the end
I saw a blank /etc/cups/interfaces/dellcolor, while I saw no
/etc/cups/interfaces/dellcolor.ppd . This is strange!

I am reporting this bug per chance someone can help out and fix this problem.


-- System Information:
Debian Release: 7.0
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.2.0-4-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages cups depends on:
ii  adduser                3.113+nmu3
ii  bc                     1.06.95-2+b1
ii  cups-client            1.5.3-5
ii  cups-common            1.5.3-5
ii  cups-filters           1.0.18-2.1
ii  cups-ppdc              1.5.3-5
ii  debconf [debconf-2.0]  1.5.49
ii  dpkg                   1.16.10
ii  ghostscript            9.05~dfsg-6.3
ii  libavahi-client3       0.6.31-2
ii  libavahi-common3       0.6.31-2
ii  libc-bin               2.13-38
ii  libc6                  2.13-38
ii  libcups2               1.5.3-5
ii  libcupscgi1            1.5.3-5
ii  libcupsimage2          1.5.3-5
ii  libcupsmime1           1.5.3-5
ii  libcupsppdc1           1.5.3-5
ii  libdbus-1-3            1.6.8-1
ii  libgcc1                1:4.7.2-5
ii  libgnutls26            2.12.20-6
ii  libgssapi-krb5-2       1.10.1+dfsg-5
ii  libkrb5-3              1.10.1+dfsg-5
ii  libldap-2.4-2          2.4.31-1+nmu2
ii  libpam0g               1.1.3-7.1
ii  libpaper1              1.1.24+nmu2
ii  libslp1                1.2.1-9
ii  libstdc++6             4.7.2-5
ii  libusb-1.0-0           2:1.0.11-1
ii  lsb-base               4.1+Debian8
ii  poppler-utils          0.18.4-6
ii  procps                 1:3.3.3-3
ii  ssl-cert               1.0.32

Versions of packages cups recommends:
ii  avahi-daemon               0.6.31-2
pn  colord                     <none>
ii  foomatic-filters           4.0.17-1
ii  ghostscript-cups           9.05~dfsg-6.3
ii  printer-driver-gutenprint  5.2.9-1

Versions of packages cups suggests:
ii  cups-bsd                                   1.5.3-5
pn  cups-pdf                                   <none>
ii  foomatic-db-compressed-ppds [foomatic-db]  20120523-1
ii  hplip                                      3.12.6-3.1
ii  printer-driver-hpcups                      3.12.6-3.1
ii  smbclient                                  2:3.6.6-6
ii  udev                                       175-7.2

-- debconf information:
  cupsys/raw-print: true
  cupsys/backend: ipp, lpd, socket, usb, snmp, dnssd

Reply to: